summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRussell Harmon (eatnumber1) <eatnumber1@gmail.com>2010-01-04 19:53:17 +0000
committerRussell Harmon (eatnumber1) <eatnumber1@gmail.com>2010-01-04 19:53:17 +0000
commit1dd025acadd9300f71f5788cfcb175af57e25260 (patch)
tree3cdaa7953e6f277ba4a65545363805f3bf79b739 /sys-block
parentmedia-sound/abcmidi: Version bumped abcmidi to 2009.12.21. Thanks to Russell ... (diff)
downloadsunrise-reviewed-1dd025acadd9300f71f5788cfcb175af57e25260.tar.gz
sunrise-reviewed-1dd025acadd9300f71f5788cfcb175af57e25260.tar.bz2
sunrise-reviewed-1dd025acadd9300f71f5788cfcb175af57e25260.zip
sys-block/compcache-tools: New ebuild for bug 299664. Thanks to Russell Harmon
svn path=/sunrise/; revision=9804
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/compcache-tools/ChangeLog9
-rw-r--r--sys-block/compcache-tools/Manifest5
-rw-r--r--sys-block/compcache-tools/compcache-tools-0.6.ebuild33
-rw-r--r--sys-block/compcache-tools/files/compcache-tools-0.6_gentoo.patch10
-rw-r--r--sys-block/compcache-tools/metadata.xml5
5 files changed, 62 insertions, 0 deletions
diff --git a/sys-block/compcache-tools/ChangeLog b/sys-block/compcache-tools/ChangeLog
new file mode 100644
index 000000000..5c5dad347
--- /dev/null
+++ b/sys-block/compcache-tools/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-block/compcache-tools
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 04 Jan 2010; Russell Harmon (eatnumber1) <russ@eatnumber1.com>
+ +compcache-tools-0.6.ebuild, +files/compcache-tools-0.6_gentoo.patch,
+ +metadata.xml:
+ New ebuild for bug 299664. Thanks to Russell Harmon
+
diff --git a/sys-block/compcache-tools/Manifest b/sys-block/compcache-tools/Manifest
new file mode 100644
index 000000000..1e6e38b75
--- /dev/null
+++ b/sys-block/compcache-tools/Manifest
@@ -0,0 +1,5 @@
+AUX compcache-tools-0.6_gentoo.patch 482 RMD160 cdbe4ec6250801fda0aec7ec57df6985221ec2eb SHA1 2449d1d0c9bd588521681c19f5a191c3bc521315 SHA256 790a860f39d77a0a6b81f4f343c780cb3f685c1ad5721cd8c2a94e8313187a6d
+DIST compcache-0.6.tar.gz 33881 RMD160 3305a428247d7e187a43fba84104ff0ca8ff2daf SHA1 4e9bada83a32654bcb18a8dc5830a13c43848547 SHA256 e5f697be6c1b7bfb9ac9ba5b8d836ff20f880c161f998c482caba83caf443c0c
+EBUILD compcache-tools-0.6.ebuild 624 RMD160 832df6840f0990f462f2701ca243ff4ce9353b35 SHA1 0ac2c59570a62b15b42568f3c75e2373fe2c16b4 SHA256 d9bfc8378e8b567965d16c4d3b2d6e7bfa8cdbe295bd19b57a34d4954d325234
+MISC ChangeLog 335 RMD160 3374d6d364a65434b14d217f50b0e985e8d8de34 SHA1 7058896fd59e5c7536d76aec46c83381946350f1 SHA256 682e29167642b672716150bfb4392cfef1052d371f65dec0f98ef64368b07f6c
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/sys-block/compcache-tools/compcache-tools-0.6.ebuild b/sys-block/compcache-tools/compcache-tools-0.6.ebuild
new file mode 100644
index 000000000..b50bde954
--- /dev/null
+++ b/sys-block/compcache-tools/compcache-tools-0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+MY_P="${P/-tools/}"
+DESCRIPTION="Compressed in-memory swap device for Linux"
+HOMEPAGE="http://code.google.com/p/compcache/"
+SRC_URI="http://compcache.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}/sub-projects/rzscontrol"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}_gentoo.patch"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin rzscontrol || die
+ doman man/rzscontrol.1 || die
+}
diff --git a/sys-block/compcache-tools/files/compcache-tools-0.6_gentoo.patch b/sys-block/compcache-tools/files/compcache-tools-0.6_gentoo.patch
new file mode 100644
index 000000000..9c454b1fe
--- /dev/null
+++ b/sys-block/compcache-tools/files/compcache-tools-0.6_gentoo.patch
@@ -0,0 +1,10 @@
+diff -ur a/sub-projects/rzscontrol/Makefile b/sub-projects/rzscontrol/Makefile
+--- a/sub-projects/rzscontrol/Makefile 2009-08-18 20:10:04.000000000 -0400
++++ b/sub-projects/rzscontrol/Makefile 2010-01-01 07:17:16.659296141 -0500
+@@ -1,5 +1,5 @@
+ all:
+- @gcc -g -Wall -D_GNU_SOURCE rzscontrol.c -o rzscontrol -I ../include -I../..
++ $(CC) $(CFLAGS) -Wall -D_GNU_SOURCE rzscontrol.c -o rzscontrol -I ../include -I../.. $(LDFLAGS)
+
+ doc:
+ @xmllint --noout --valid man/rzscontrol.xml
diff --git a/sys-block/compcache-tools/metadata.xml b/sys-block/compcache-tools/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/sys-block/compcache-tools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>