summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pdfedit/pdfedit-0.4.1.ebuild')
-rw-r--r--app-text/pdfedit/pdfedit-0.4.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/pdfedit/pdfedit-0.4.1.ebuild b/app-text/pdfedit/pdfedit-0.4.1.ebuild
new file mode 100644
index 000000000..39663b611
--- /dev/null
+++ b/app-text/pdfedit/pdfedit-0.4.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Editor for manipulating PDF documents. GUI and commandline interface."
+HOMEPAGE="http://pdfedit.petricek.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+RDEPEND="=x11-libs/qt-3*"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+src_compile(){
+ econf || die "econf failed"
+ emake src || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+}