summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2007-06-04 21:52:35 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2007-06-04 21:52:35 +0000
commitb75ef8edbdc783b83f389af9648c3bd65d2225ef (patch)
treec279235c1d07d086cb2ce6848f771f8a1583681a /dev-dotnet
parentMove to Manifest2, maybe I broke some ancient asterisk packages which are no ... (diff)
downloadvoip-b75ef8edbdc783b83f389af9648c3bd65d2225ef.tar.gz
voip-b75ef8edbdc783b83f389af9648c3bd65d2225ef.tar.bz2
voip-b75ef8edbdc783b83f389af9648c3bd65d2225ef.zip
Moving and updating {telepathy,tapioca}-sharp
svn path=/trunk/; revision=503
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/tapioca-sharp/ChangeLog8
-rw-r--r--dev-dotnet/tapioca-sharp/Manifest1
-rw-r--r--dev-dotnet/tapioca-sharp/tapioca-sharp-9999.ebuild40
-rw-r--r--dev-dotnet/telepathy-sharp/ChangeLog8
-rw-r--r--dev-dotnet/telepathy-sharp/Manifest1
-rw-r--r--dev-dotnet/telepathy-sharp/telepathy-sharp-9999.ebuild32
6 files changed, 90 insertions, 0 deletions
diff --git a/dev-dotnet/tapioca-sharp/ChangeLog b/dev-dotnet/tapioca-sharp/ChangeLog
new file mode 100644
index 0000000..d269015
--- /dev/null
+++ b/dev-dotnet/tapioca-sharp/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-dotnet/tapioca-sharp
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2006/02/22 02:08:04 hd_brummy Exp $
+
+ 04 Jun 2007; Santiago M. Mola <gentoo@coldwind.org>
+ +tapioca-sharp-9999.ebuild:
+ Initial ebuild.
+
diff --git a/dev-dotnet/tapioca-sharp/Manifest b/dev-dotnet/tapioca-sharp/Manifest
new file mode 100644
index 0000000..fba5db7
--- /dev/null
+++ b/dev-dotnet/tapioca-sharp/Manifest
@@ -0,0 +1 @@
+EBUILD tapioca-sharp-9999.ebuild 1093 RMD160 bd30122036d898606baa4e92c6cd57d80c21dd15 SHA1 a680176e3ce3a30f47c001a077aa5fc9c63905f8 SHA256 f7b7fde8aa32afca5bb290fce0208de925206d6b69af7f94fc2f91ad3cc8fd6a
diff --git a/dev-dotnet/tapioca-sharp/tapioca-sharp-9999.ebuild b/dev-dotnet/tapioca-sharp/tapioca-sharp-9999.ebuild
new file mode 100644
index 0000000..4e41b88
--- /dev/null
+++ b/dev-dotnet/tapioca-sharp/tapioca-sharp-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/tapiocaui/tapiocaui-0.3.0.ebuild,v 1.2 2006/05/22 00:15:21 genstef Exp $
+
+inherit subversion mono
+
+DESCRIPTION="C# bindings for Tapioca."
+HOMEPAGE="http://tapioca-voip.sf.net"
+#SRC_URI="mirror://sourceforge/tapioca-voip/${P}.tar.gz"
+ESVN_REPO_URI="https://tapioca-voip.svn.sourceforge.net/svnroot/tapioca-voip/trunk/tapioca-sharp"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="net-im/tapiocad
+ >=dev-dotnet/gtk-sharp-2.8.2
+ >=dev-dotnet/gnome-sharp-2.8.2
+ >=dev-dotnet/glade-sharp-2.8.2
+ >=dev-dotnet/gconf-sharp-2.8.2
+ dev-dotnet/gnomevfs-sharp
+ gnome-base/gnome-common
+ dev-dotnet/telepathy-sharp
+ gnome-base/gconf
+ media-libs/farsight
+ media-libs/gstreamer
+ >=media-libs/gst-plugins-base-0.10.5"
+# net-im/tapioca-xmpp
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}"
+ NOCONFIGURE=1 ./autogen.sh || die "./autogen.sh failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/dev-dotnet/telepathy-sharp/ChangeLog b/dev-dotnet/telepathy-sharp/ChangeLog
new file mode 100644
index 0000000..cbe0b0a
--- /dev/null
+++ b/dev-dotnet/telepathy-sharp/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-dotnet/telepathy-sharp
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2006/02/22 02:08:04 hd_brummy Exp $
+
+ 04 Jun 2007; Santiago M. Mola <gentoo@coldwind.org>
+ +telepathy-sharp-9999.ebuild:
+ Initial ebuild.
+
diff --git a/dev-dotnet/telepathy-sharp/Manifest b/dev-dotnet/telepathy-sharp/Manifest
new file mode 100644
index 0000000..ce99ebe
--- /dev/null
+++ b/dev-dotnet/telepathy-sharp/Manifest
@@ -0,0 +1 @@
+EBUILD telepathy-sharp-9999.ebuild 884 RMD160 4dec808910e74b078334b3e1f6b541137c8820d6 SHA1 1c30e5dc00ac61eaac489a908bdaa9e6c11f8aa3 SHA256 be639a92fd18d5676c418b5cc6c392b4979bcf3f780effc636959069ec9badcb
diff --git a/dev-dotnet/telepathy-sharp/telepathy-sharp-9999.ebuild b/dev-dotnet/telepathy-sharp/telepathy-sharp-9999.ebuild
new file mode 100644
index 0000000..5893ba9
--- /dev/null
+++ b/dev-dotnet/telepathy-sharp/telepathy-sharp-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/tapiocaui/tapiocaui-0.3.0.ebuild,v 1.2 2006/05/22 00:15:21 genstef Exp $
+
+inherit subversion mono
+
+DESCRIPTION="Telepathy C# bindings"
+HOMEPAGE="http://telepathy.freedesktop.org/wiki/TelepathySharp"
+#SRC_URI="mirror://sourceforge/tapioca-voip/${P}.tar.gz"
+ESVN_REPO_URI="https://tapioca-voip.svn.sourceforge.net/svnroot/tapioca-voip/trunk/telepathy-sharp"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/mono
+ net-libs/libtelepathy
+ dev-dotnet/ndesk-dbus
+ gnome-base/gnome-common"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}"
+ NOCONFIGURE=1 ./autogen.sh || die "./autogen.sh failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS COPYING
+}