summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2006-01-20 08:51:32 +0000
committerStefan Knoblich <stkn@gentoo.org>2006-01-20 08:51:32 +0000
commit05914020b3169dae56a84c17fc8429198f6990ff (patch)
treed7605fa054138e657a1355ada16674d069ffad08 /dev-libs
parent[NEW] rev bumped asterisk to 1.2.1-r1, updating bristuff to 0.3.0-PRE1f (diff)
downloadvoip-05914020b3169dae56a84c17fc8429198f6990ff.tar.gz
voip-05914020b3169dae56a84c17fc8429198f6990ff.tar.bz2
voip-05914020b3169dae56a84c17fc8429198f6990ff.zip
Add work-in-progress version of pwlib-1.9.2 ebuild
svn path=/trunk/; revision=95
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/pwlib/pwlib-1.9.2.ebuild179
1 files changed, 179 insertions, 0 deletions
diff --git a/dev-libs/pwlib/pwlib-1.9.2.ebuild b/dev-libs/pwlib/pwlib-1.9.2.ebuild
new file mode 100644
index 0000000..9db6471
--- /dev/null
+++ b/dev-libs/pwlib/pwlib-1.9.2.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pwlib/pwlib-1.8.4.ebuild,v 1.2 2005/07/10 01:11:05 swegener Exp $
+
+inherit eutils flag-o-matic multilib
+
+IUSE="alsa esd ieee1394 ipv6 oss sdl ssl v4l2"
+
+DESCRIPTION="Portable Multiplatform Class Libraries for OpenH323"
+HOMEPAGE="http://www.voxgratia.org/"
+SRC_URI="http://www.voxgratia.org/releases/pwlib-v${PV//./_}-src-tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="-*"
+
+RDEPEND="
+ dev-libs/expat
+ net-nds/openldap
+ sdl? ( media-libs/libsdl )
+ ssl? ( dev-libs/openssl )
+ alsa? ( media-libs/alsa-lib )
+ ieee1394? ( media-libs/libdv
+ sys-libs/libavc1394
+ sys-libs/libraw1394
+ <media-libs/libdc1394-1.9.99
+ !>=media-libs/libdc1394-2.0.0_pre1 )
+ esd? ( media-sound/esound )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.5.4a
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}_v${PV//./_}"
+
+src_unpack() {
+ tar -xzf ${DISTDIR}/${A} -C ${WORKDIR} || die "Unpacking failed"
+
+ cd ${S}
+
+ # filter out -O3 and -mcpu embedded compiler flags
+ sed -i \
+ -e "s:-mcpu=\$(CPUTYPE)::" \
+ -e "s:-O3 -DNDEBUG:-DNDEBUG:" \
+ make/unix.mak
+
+ # newer esound package doesn't install libesd.a anymore,
+ # use dynamic library instead (fixes #100432)
+ epatch ${FILESDIR}/pwlib-1.6.3-dyn-esd.patch
+
+ # don't break make install if there are no plugins to install
+ epatch ${FILESDIR}/pwlib-1.8.7-instplugins.diff
+}
+
+src_compile() {
+ local myconf=""
+
+ # may cause ICE (bug #70638)
+ filter-flags -fstack-protector
+
+# if use ssl; then
+# export OPENSSLFLAG=1
+# export OPENSSLDIR="/usr"
+# export OPENSSLLIBS="-lssl -lcrypt"
+# fi
+
+ ## gnomemeeting-1.00 requires pwlib to be built w/ IPV6 support
+ ## (even if itself is built without...)
+ #use ipv6 \
+ # && myconf="${myconf} --enable-ipv6" \
+ # || myconf="${myconf} --disable-ipv6"
+# myconf="--enable-ipv6"
+
+ if use esd; then
+ # fixes bug #45059
+ export ESDDIR=/usr
+
+ # ESD includes are in /usr/include?
+ # remove include path, bad things may happen if we leave it in there
+ sed -i -e "s:-I\$(ESDDIR)/include::" \
+ ${S}/make/unix.mak
+ fi
+
+ econf \
+ --enable-plugins \
+ $(use_enable v4l2) \
+ $(use_enable ieee1394 dc) \
+ $(use_enable ieee1394 avc) \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ $(use_enable ipv6) \
+ ${myconf} || die "configure failed"
+
+ # Horrible hack to strip out -L/usr/lib to allow upgrades
+ # problem is it adds -L/usr/lib before -L${S} when SSL is
+ # enabled. Same thing for -I/usr/include.
+# sed -i -e "s:^\(LDFLAGS.*\)-L/usr/lib:\1:" \
+# -e "s:^\(STDCCFLAGS.*\)-I/usr/include:\1:" \
+# ${S}/make/ptbuildopts.mak
+
+# sed -i -e "s:^\(LDFLAGS[\s]*=.*\) -L/usr/lib:\1:" \
+# -e "s:^\(LDFLAGS[\s]*=.*\) -I/usr/include:\1:" \
+# -e "s:^\(CCFLAGS[\s]*=.*\) -I/usr/include:\1:" \
+# ${S}/make/ptlib-config
+
+ emake -j1 opt || die "make failed"
+}
+
+#pkg_preinst() {
+# # remove {lib,include} directories in /usr/share/pwlib
+# # they are getting replaced by symlinks in src_install
+#
+# if [[ -d ${ROOT}usr/share/pwlib/include ]]; then
+# rm -rf ${ROOT}usr/share/pwlib/include
+# fi
+# if [[ -d ${ROOT}usr/share/pwlib/$(get_libdir) ]]; then
+# rm -rf ${ROOT}usr/share/pwlib/$(get_libdir)
+# fi
+#}
+
+src_install() {
+ local libdir libname
+
+ libdir=$(get_libdir)
+
+ # makefile doesn't create ${D}/usr/bin
+# dodir /usr/bin
+ make PREFIX=/usr DESTDIR=${D} install || die "install failed"
+
+ ## vv will try to fix the mess below, requires a lot of patching though...
+
+ # update 2005/08/22:
+ #
+ # locations in *.mak files haven been fixed
+ # directories have been replaced w/ symlinks
+ # (left to not break things, doing some testing atm)
+
+# dosym /usr/include /usr/share/pwlib/include
+# dosym /usr/${libdir} /usr/share/pwlib/${libdir}
+#
+# # just in case...
+# if [[ "${libdir}" = "lib64" ]]; then
+# dosym /usr/share/pwlib/lib64 /usr/share/pwlib/lib
+# fi
+
+ ## ^^ bad stuff
+
+ # fix symlink
+ rm ${D}/usr/${libdir}/libpt.so
+
+ libname=$(basename `ls ${D}/usr/${libdir}/libpt_*_*_r.so.${PV}`)
+ dosym /usr/${libdir}/${libname} /usr/${libdir}/libpt.so
+
+ # strip ${S} stuff
+# sed -i -e "s:^PWLIBDIR.*:PWLIBDIR=/usr/share/pwlib:" \
+# ${D}/usr/bin/ptlib-config \
+# ${D}/usr/share/pwlib/make/ptlib-config \
+# ${D}/usr/share/pwlib/make/ptbuildopts.mak
+
+ # fix makefiles to use headers from /usr/include and libs from /usr/lib
+ # instead of /usr/share/pwlib
+ sed -i -e "s:-I\$(PWLIBDIR)\(/include[a-zA-Z0-9_/-]\+\):-I/usr/include\1:g" \
+ -e "s:-I\$(PWLIBDIR)/include::g" \
+ -e "s:^\(PW_LIBDIR[ \t]\+=\).*:\1 /usr/${libdir}:" \
+ ${D}/usr/share/pwlib/make/*.mak
+
+ # dodgy configure/makefiles forget to expand this
+ sed -i -e "s:\${exec_prefix}:/usr:" \
+ ${D}/usr/bin/ptlib-config \
+ ${D}/usr/share/pwlib/make/ptlib-config
+
+ # copy version.h
+ insinto /usr/share/pwlib
+ doins version.h
+
+ dodoc ReadMe.txt ReadMe_QOS.txt History.txt mpl-1.0.htm
+}