summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/mount/Makefile')
-rw-r--r--src/mount/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/mount/Makefile b/src/mount/Makefile
new file mode 100644
index 0000000..84305c8
--- /dev/null
+++ b/src/mount/Makefile
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+CC = gcc
+LD = gcc
+
+CFLAGS = -Wall -O2
+DESTDIR =
+LIBDIR = lib
+
+BIN_TARGETS =
+SBIN_TARGETS = mount
+SYS_WHITELIST =
+
+TARGET = $(BIN_TARGETS) $(SBIN_TARGETS)
+
+OS = Linux
+ifeq ($(OS),Linux)
+LDFLAGS_RS = -ldl
+endif
+ifeq ($(OS),BSD)
+LDFLAGS_SSD = -lkvm
+endif
+
+override CFLAGS += -DLIBDIR=\"$(LIBDIR)\"
+
+all: $(TARGET)
+
+mount: mount.o
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LDFLAGS_SSD)
+
+install: $(TARGET)
+ install -m 0755 -d $(DESTDIR)/sbin
+ install -m 0755 $(SBIN_TARGETS) $(DESTDIR)/sbin
+
+clean:
+ rm -f $(TARGET)
+ rm -f *.o *~