summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/roundcube/roundcube-0.1.ebuild')
-rw-r--r--mail-client/roundcube/roundcube-0.1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/mail-client/roundcube/roundcube-0.1.ebuild b/mail-client/roundcube/roundcube-0.1.ebuild
new file mode 100644
index 0000000..995f8cb
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit webapp depend.php depend.apache
+
+MY_PN="${PN}mail"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A browser-based multilingual IMAP client using AJAX"
+HOMEPAGE="http://www.roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql postgres sqlite ssl"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ local flags="crypt iconv imap pcre unicode"
+ use ssl && flags="${flags} ssl"
+ use spell && flags="${flags} curl socket"
+ local dbflags="mysql postgres sqlite"
+ if ! use mysql && ! use postgres && ! use sqlite ; then
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ! PHPCHECKNODIE="yes" require_php_with_any_use ${dbflags} ; then
+ die "Re-install ${PHP_PKG} with ${flags} and at least one of ${dbflags} in USE."
+ fi
+ else
+ for db in ${dbflags} ; do
+ use ${db} && flags="${flags} ${db}"
+ done
+ require_php_with_use ${flags}
+ fi
+ webapp_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/config
+ mv db.inc.php.dist db.inc.php
+ mv main.inc.php.dist main.inc.php
+}
+
+src_install () {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README UPGRADING
+
+ cp -R [[:lower:]]* SQL "${D}/${MY_HTDOCSDIR}"
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}