summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-05-26 20:55:02 +0200
committerChristoph Mende <angelos@gentoo.org>2010-05-26 20:55:02 +0200
commitfd4080048d2e8a2099bf056de7a2c7e4b60c9e73 (patch)
tree0ab08bad630b6c17096bb741e72b4ad2253e1534 /xfce-base/xfce4-session
parentlibxfce4util: Updated (diff)
downloadxfce-fd4080048d2e8a2099bf056de7a2c7e4b60c9e73.tar.gz
xfce-fd4080048d2e8a2099bf056de7a2c7e4b60c9e73.tar.bz2
xfce-fd4080048d2e8a2099bf056de7a2c7e4b60c9e73.zip
xfce4-session: Updated and prepared upower support
Diffstat (limited to 'xfce-base/xfce4-session')
-rw-r--r--xfce-base/xfce4-session/Manifest2
-rw-r--r--xfce-base/xfce4-session/xfce4-session-9999.ebuild72
2 files changed, 51 insertions, 23 deletions
diff --git a/xfce-base/xfce4-session/Manifest b/xfce-base/xfce4-session/Manifest
index db3128e..d1df68e 100644
--- a/xfce-base/xfce4-session/Manifest
+++ b/xfce-base/xfce4-session/Manifest
@@ -1,2 +1,2 @@
-EBUILD xfce4-session-9999.ebuild 841 RMD160 3a862f687084492a2778c8914498acededab2dbc SHA1 ce1117b92559e19f095b66a555dfeed0a382e177 SHA256 d9f4d75f356a51a1f9aa8ad4f03662514e4af600e64982fc04cb14cdb3323a2b
+EBUILD xfce4-session-9999.ebuild 1835 RMD160 ffcb4a2fbcf3cbf36642a7da14e9f83ec06017b5 SHA1 5d63ccafd8866525b5d5038ed1d4e11a2734326d SHA256 c4694763e2fe6c3c15a556bf6480628f362b2eadd1165ba8ba3f2f4102d7287f
MISC metadata.xml 157 RMD160 d7470fe88d1b96f3a7f1ef26fb7dc646b4a1b907 SHA1 7eae91f2588bdae8667d37a98fb3090d539eeca1 SHA256 44350daa7594842894d676413708d8ea77ccb0017bed24711af5b256281f5e61
diff --git a/xfce-base/xfce4-session/xfce4-session-9999.ebuild b/xfce-base/xfce4-session/xfce4-session-9999.ebuild
index 8ab542a..1521bb6 100644
--- a/xfce-base/xfce4-session/xfce4-session-9999.ebuild
+++ b/xfce-base/xfce4-session/xfce4-session-9999.ebuild
@@ -1,34 +1,62 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=2
inherit xfce4
xfce4_core
-DESCRIPTION="Session manager"
+DESCRIPTION="Session manager for Xfce4"
HOMEPAGE="http://www.xfce.org/projects/xfce4-session/"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug gnome"
-
-RDEPEND="gnome-base/libglade
- dev-libs/dbus-glib
- sys-apps/dbus
- x11-libs/libX11
- x11-libs/libSM
- x11-libs/libwnck
- x11-apps/iceauth
- xfce-base/exo
- >=xfce-base/libxfce4util-${XFCE_VERSION}
- >=xfce-base/libxfcegui4-${XFCE_VERSION}
- >=xfce-base/xfconf-${XFCE_VERSION}
- >=xfce-base/xfce-utils-${XFCE_VERSION}
- games-misc/fortune-mod
- gnome? ( gnome-base/gconf
- gnome-base/gnome-keyring )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="consolekit debug fortune gnome gnome-keyring policykit"# upower
+
+RDEPEND=">=dev-libs/dbus-glib-0.73
+ >=x11-libs/gtk+-2.14:2
+ >=x11-libs/libwnck-2.22
+ >=xfce-base/libxfce4ui-4.7
+ >=xfce-base/libxfce4util-4.7
+ >=xfce-base/xfce4-panel-4.6
+ >=xfce-base/xfconf-4.7
+ consolekit? ( sys-auth/consolekit )
+ fortune? ( games-misc/fortune-mod )
+ gnome? ( >=gnome-base/gconf-2.4 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.22 )
+ policykit? ( sys-auth/polkit )"
+ #upower? ( sys-power/upower )
DEPEND="${RDEPEND}
dev-util/intltool"
-XFCE_CONFIG+=" $(use_enable gnome)"
+pkg_setup() {
+ XFCE_CONFIG+=" --disable-hal
+ --enable-panel-plugin
+ $(use_enable consolekit)
+ $(use_enable gnome)
+ $(use_enable gnome-keyring libgnome-keyring)
+ $(use_enable policykit polkit)"
+ #$(use_enable upower)
+ DOCS="AUTHORS BUGS NEWS README TODO"
+}
+
+src_install() {
+ xfce4_src_install
+
+ if ! use fortune; then
+ # Wipe away unusable xfce4-tips
+ rm -Rf "${D}"/usr/share/xfce4/tips
+ rm -f "${D}"/usr/bin/xfce4-tips \
+ "${D}"/usr/lib/debug/usr/bin/xfce4-tips.debug \
+ "${D}"/etc/xdg/autostart/xfce4-tips-autostart.desktop
+ rmdir -p "${D}"/etc/xdg/autostart
+ fi
+}
-DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+pkg_postinst() {
+ if ! use consolekit; then # && ! use upower
+ einfo "consolekit is disabled, you will need sudo to shutdown as user"
+ einfo "Please add the following to your sudoers file:"
+ einfo "myuser myhost=${EPREFIX}/usr/libexec/xfsm-shutdown-helper"
+ einfo "Where myuser is your user and myhost your hostname"
+ fi
+}