summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-01-01 16:14:47 +0000
committerSteve Dibb <beandog@gentoo.org>2010-01-01 16:14:47 +0000
commit4faa73d97e340612f5212458852df7e045b131de (patch)
tree6f275a57b4d9ecd63b2266882fafdd1a2f148e76
parentupdate package statuses; fix import bugzilla bug where all bugs would get del... (diff)
downloadznurt-org-backend-4faa73d97e340612f5212458852df7e045b131de.tar.gz
znurt-org-backend-4faa73d97e340612f5212458852df7e045b131de.tar.bz2
znurt-org-backend-4faa73d97e340612f5212458852df7e045b131de.zip
new mtimes
git-svn-id: file:///var/svn/portage@34 3218660a-b0cf-4799-a991-8ddcc5b9e0f3
-rw-r--r--class.portage.ebuild.php26
1 files changed, 10 insertions, 16 deletions
diff --git a/class.portage.ebuild.php b/class.portage.ebuild.php
index d1a1efb..97cea90 100644
--- a/class.portage.ebuild.php
+++ b/class.portage.ebuild.php
@@ -44,8 +44,6 @@
// File properties
private $filename;
- private $mtime;
- private $ctime;
private $category;
@@ -55,6 +53,12 @@
public $arr_components;
private $has_version;
+ // File mtimes
+ private $portage_mtime;
+ private $changelog_mtime;
+ private $metadata_mtime;
+ private $cache_mtime;
+
function __construct($str) {
$this->atom = trim($str);
@@ -67,6 +71,9 @@
$this->filename = $this->portage."/".$this->getCategory()."/".$this->getPackageName()."/".$this->getFullPackageName().".ebuild";
$this->filename_cache = $this->cache."/".$this->getCategory()."/".$this->getFullPackageName();
+
+ if(file_exists($this->filename_cache))
+ $this->cache_mtime = filemtime($this->filename_cache);
$this->arr_metadata_keys = array('depend', 'rdepend', 'slot', 'src_uri', 'restrict', 'homepage', 'license', 'description', 'keywords', 'inherited', 'iuse', 'cdepend', 'pdepend', 'provide', 'eapi', 'properties', 'defined_phases');
@@ -143,14 +150,10 @@
return $this->getPackageVersionAndRevision();
break;
- case 'mtime':
+ case 'portage_mtime':
return $this->getMtime();
break;
- case 'ctime':
- return $this->getCtime();
- break;
-
case 'filename':
return $this->filename;
break;
@@ -497,15 +500,6 @@
}
- function getCtime() {
-
- if(file_exists($this->filename))
- return filectime($this->filename);
- else
- return null;
-
- }
-
}
?> \ No newline at end of file