summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/avant-window-navigator-extras/avant-window-navigator-extras-9999.ebuild')
-rw-r--r--gnome-extra/avant-window-navigator-extras/avant-window-navigator-extras-9999.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnome-extra/avant-window-navigator-extras/avant-window-navigator-extras-9999.ebuild b/gnome-extra/avant-window-navigator-extras/avant-window-navigator-extras-9999.ebuild
new file mode 100644
index 0000000..119a7cc
--- /dev/null
+++ b/gnome-extra/avant-window-navigator-extras/avant-window-navigator-extras-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit gnome2 bzr autotools
+
+EBZR_REPO_URI="http://bazaar.launchpad.net/~awn-extras/awn-extras/"
+
+DESCRIPTION="Awn-extras provides applets for the Awn application"
+HOMEPAGE="http://code.google.com/p/avant-window-navigator/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="gnome-extra/avant-window-navigator
+ >=x11-libs/gtk+-2.0
+ >=gnome-base/gnome-desktop-2.0
+ >=gnome-base/librsvg-2.0
+ gnome-base/gnome-menus"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+src_compile() {
+
+ for dir in `find "${S}"/awn-* -mindepth 1 -type d`;
+ do
+ cd "${dir}"
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc
+ gnome2_src_compile
+ cd "${S}"
+ done
+}
+
+src_install() {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+
+ for dir in `find "${S}"/awn-* -mindepth 1 -type d`;
+ do
+ cd "${dir}"
+ emake DESTDIR="${D}" install || die "make install of ${x} failed"
+ cd "${S}"
+ done
+}
+
+pkg_postinst() {
+ ewarn "DO NOT report bugs to Gentoo's bugzilla"
+ einfo "Please report all bugs at http://bugs.gentoo-xeffects.org"
+ einfo "Thank you on behalf of the Gentoo Xeffects team"
+ einfo "If you want plugins for awn they can be downloaded at"
+ einfo "http://codebrowse.launchpad.net/~awn-extras/awn-extras/trunk/files/"
+}