summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-08-10 12:26:18 +0200
committerMichał Górny <mgorny@gentoo.org>2014-08-10 12:26:18 +0200
commit60e0e0b4c629a90434931dd08a1b629fe1e2a1fa (patch)
tree85b02c18d1a58c86532b7f799bb7a59ea50a4fc9
parentsys-apps/portage: Introduce ebuild for new-install branch of portage. (diff)
downloadmgorny-60e0e0b4c629a90434931dd08a1b629fe1e2a1fa.tar.gz
mgorny-60e0e0b4c629a90434931dd08a1b629fe1e2a1fa.tar.bz2
mgorny-60e0e0b4c629a90434931dd08a1b629fe1e2a1fa.zip
sys-apps/portage: Install preferred impl shebangs rather than random ones.
Package-Manager: portage-2.2.11_p29
-rw-r--r--sys-apps/portage/portage-9999.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index a4b3ccd..a7780ad 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -188,9 +188,8 @@ python_install_all() {
use doc && targets+=( install_docbook )
use epydoc && targets+=( install_epydoc )
- if [[ ${targets[@]} ]]; then
- python_install "${targets[@]}"
- fi
+ # install docs + replace scripts with preferred impl
+ python_install "${targets[@]}"
}
pkg_preinst() {