summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-06-09 09:59:39 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-06-09 09:59:39 -0400
commit0ade26cf8a702ab1252bba92dae584a7f2b7c102 (patch)
tree92a5473cbcf8fb4d8232fea7d7117b3d82c64136
parentgnome-extra/nm-applet: Bump to 1.8.22 (diff)
downloadgentoo-0ade26cf8a702ab1252bba92dae584a7f2b7c102.tar.gz
gentoo-0ade26cf8a702ab1252bba92dae584a7f2b7c102.tar.bz2
gentoo-0ade26cf8a702ab1252bba92dae584a7f2b7c102.zip
dev-python/pytest-relaxed: remove last-rited package
Closes: https://bugs.gentoo.org/685538 Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
-rw-r--r--dev-python/pytest-relaxed/Manifest2
-rw-r--r--dev-python/pytest-relaxed/files/pytest-relaxed-1.1.4-no-autoload.patch12
-rw-r--r--dev-python/pytest-relaxed/metadata.xml12
-rw-r--r--dev-python/pytest-relaxed/pytest-relaxed-1.1.0.ebuild31
-rw-r--r--dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild41
-rw-r--r--profiles/package.mask5
6 files changed, 0 insertions, 103 deletions
diff --git a/dev-python/pytest-relaxed/Manifest b/dev-python/pytest-relaxed/Manifest
deleted file mode 100644
index b15fdf92d8c3..000000000000
--- a/dev-python/pytest-relaxed/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST pytest-relaxed-1.1.0.tar.gz 25942 BLAKE2B 6dd34044ec3ae0b5c85f0a76102aaeafe3dad8748c0cf34666dd3550162a2968191efb8415467259a4f072905af062aeabaaaeb475ab68d47aa8d79e3cadd3d0 SHA512 010e37c4d0c63bd00af8851bb50e52af7f8f17769be042e4941e8d8ba451920c24dfa6cdf74cd1b3ca4b3e1c71cd5e1ac34ffae855fc261cf431c212f98cbfff
-DIST pytest-relaxed-1.1.4.tar.gz 26854 BLAKE2B c9b4d7c5c68fb24deaa9b107960eec7b24ab1cfe4ed37f0ffa99b4e5a9d3572be860ff3bc39882f5024fb6aad73f5f976c450294cf713483bba655af56b70245 SHA512 d4e7ed5143ac9f1bff1f911e4ab3aede076d154dcecc28ce96cbc49782d186214893b942a3548da2789faa51df5ddbd43ff41c82b9bb9d0d52f38a2000fc0c6b
diff --git a/dev-python/pytest-relaxed/files/pytest-relaxed-1.1.4-no-autoload.patch b/dev-python/pytest-relaxed/files/pytest-relaxed-1.1.4-no-autoload.patch
deleted file mode 100644
index b176e4e86c3e..000000000000
--- a/dev-python/pytest-relaxed/files/pytest-relaxed-1.1.4-no-autoload.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 28c72c7..6feca5b 100644
---- a/setup.py
-+++ b/setup.py
-@@ -22,7 +22,6 @@ setup(
- packages=find_packages(),
- entry_points={
- # TODO: do we need to name the LHS 'pytest_relaxed' too? meh
-- "pytest11": ["relaxed = pytest_relaxed.plugin"]
- },
- install_requires=[
- # NOTE: pytest 3.3 broke something, not sure what yet
diff --git a/dev-python/pytest-relaxed/metadata.xml b/dev-python/pytest-relaxed/metadata.xml
deleted file mode 100644
index 2d23528854f3..000000000000
--- a/dev-python/pytest-relaxed/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">pytest-relaxed</remote-id>
- <remote-id type="github">bitprophet/pytest-relaxed</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pytest-relaxed/pytest-relaxed-1.1.0.ebuild b/dev-python/pytest-relaxed/pytest-relaxed-1.1.0.ebuild
deleted file mode 100644
index 1fd62c11b70a..000000000000
--- a/dev-python/pytest-relaxed/pytest-relaxed-1.1.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for relaxed test discovery and organization"
-HOMEPAGE="https://pypi.org/project/pytest-relaxed/ https://github.com/bitprophet/pytest-relaxed"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD-2"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/pytest-3[${PYTHON_USEDEP}]
- >=dev-python/six-1[${PYTHON_USEDEP}]
- >=dev-python/decorator-4[${PYTHON_USEDEP}]
-"
-DEPEND="test? ( ${RDEPEND} )"
-
-# various misc failures
-RESTRICT="test"
-
-python_test() {
- py.test || die "tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild b/dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild
deleted file mode 100644
index 1e8201173b13..000000000000
--- a/dev-python/pytest-relaxed/pytest-relaxed-1.1.4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Because of its <pytest-3.3 constraint, python3_7 can't be added
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for relaxed test discovery and organization"
-HOMEPAGE="https://pypi.org/project/pytest-relaxed/ https://github.com/bitprophet/pytest-relaxed"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD-2"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/pytest-3[${PYTHON_USEDEP}]
- <dev-python/pytest-3.3
- >=dev-python/six-1[${PYTHON_USEDEP}]
- >=dev-python/decorator-4[${PYTHON_USEDEP}]
-"
-
-# This package is a broken mess upstream. Tests don't work. Fortunately, it's
-# not actually used by many packages.
-RESTRICT="test"
-
-PATCHES=(
- # We strip pytest-relaxed's entry point to stop it from autoloading on all
- # tests. When this package is installed, it has the habit of being
- # autoloaded everywhere and break every test. If you want to load it, add
- # "-p pytest_relaxed.plugin" to your pytest invocation.
- "${FILESDIR}/${PN}-1.1.4-no-autoload.patch"
-)
-
-python_test() {
- pytest -v || die "tests failed with ${EPYTHON}"
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 3eafb1ea8853..7250786a2945 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -237,11 +237,6 @@ app-accessibility/perlbox-voice
app-accessibility/pidgin-festival
dev-ros/sound_play
-# Virgil Dupras <vdupras@gentoo.org> (10 May 2019)
-# Has very limited use and is disruptive of other tests when activated.
-# Bug #685538. Removal in 30 days.
-dev-python/pytest-relaxed
-
# Patrice Clement <monsieurp@gentoo.org> (06 May 2019)
# Broken build. Outdated version. No interest from the Java team to maintain
# it. Removal in 30 days. Bug #581720.