summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-19 00:20:11 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-19 00:27:14 +0200
commit31f4a0444b539c54f45b39ebaf240711b92aa915 (patch)
tree16e59ce440dc981525554af0dd6cd853a19e1713
parentdev-ml/dune: 2.9.3 - enable Emacs support & bump to EAPI 8 (diff)
downloadgentoo-31f4a0444b539c54f45b39ebaf240711b92aa915.tar.gz
gentoo-31f4a0444b539c54f45b39ebaf240711b92aa915.tar.bz2
gentoo-31f4a0444b539c54f45b39ebaf240711b92aa915.zip
app-emacs/reformatter: new package; add version 0.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/reformatter/Manifest1
-rw-r--r--app-emacs/reformatter/files/50reformatter-gentoo.el1
-rw-r--r--app-emacs/reformatter/metadata.xml13
-rw-r--r--app-emacs/reformatter/reformatter-0.6.ebuild23
4 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/reformatter/Manifest b/app-emacs/reformatter/Manifest
new file mode 100644
index 000000000000..d11a780799b9
--- /dev/null
+++ b/app-emacs/reformatter/Manifest
@@ -0,0 +1 @@
+DIST reformatter-0.6.tar.gz 7943 BLAKE2B 72f34b873aacef5ee1dd0edd06effed83dad490f5d57ac3390dbd0d6fb7172adb1b7a3e19c0e90740b300cad8d2a1df60ab1bbfaa660c79621066d402f01b923 SHA512 ff1ad88b3a0a3ca1e70a5e0d7fe6f2264981d88ae64f0fa412d52721fb43991a483f31fb72193f7d67be71f39110051c0dda39e4ed87b4339aa156fa256e013a
diff --git a/app-emacs/reformatter/files/50reformatter-gentoo.el b/app-emacs/reformatter/files/50reformatter-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/reformatter/files/50reformatter-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/reformatter/metadata.xml b/app-emacs/reformatter/metadata.xml
new file mode 100644
index 000000000000..7cdcedd7a960
--- /dev/null
+++ b/app-emacs/reformatter/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/purcell/emacs-reformatter/issues/</bugs-to>
+ <remote-id type="github">purcell/emacs-reformatter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/reformatter/reformatter-0.6.ebuild b/app-emacs/reformatter/reformatter-0.6.ebuild
new file mode 100644
index 000000000000..81970dc35b99
--- /dev/null
+++ b/app-emacs/reformatter/reformatter-0.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.3
+
+inherit elisp
+
+DESCRIPTION="Define commands which run reformatters on the Emacs buffers"
+HOMEPAGE="https://github.com/purcell/emacs-reformatter/"
+SRC_URI="https://github.com/purcell/emacs-${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Tests need "shfmt"
+
+DOCS=( README.md )
+ELISP_REMOVE="Makefile ${PN}-tests.el" # Makefile downloads pkgs from net
+SITEFILE="50${PN}-gentoo.el"