summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Lopes <ricardoapl@protonmail.com>2023-03-09 20:17:28 +0000
committerMichael Palimaka <kensington@gentoo.org>2023-03-25 15:35:05 +1100
commit72a92706ae0422024e7df1b64efe01da4ae51b91 (patch)
treefdfdfcff5534f87d25e05b6ef5724aca89ae64a9
parentsys-fs/xfsprogs: add git repo to HOMEPAGE (diff)
downloadgentoo-72a92706ae0422024e7df1b64efe01da4ae51b91.tar.gz
gentoo-72a92706ae0422024e7df1b64efe01da4ae51b91.tar.bz2
gentoo-72a92706ae0422024e7df1b64efe01da4ae51b91.zip
app-admin/bitwarden-desktop-bin: add 2023.2.0
Closes: https://bugs.gentoo.org/898034 Closes: https://github.com/gentoo/gentoo/pull/30033 Signed-off-by: Ricardo Lopes <ricardoapl@protonmail.com> Signed-off-by: Michael Palimaka <kensington@gentoo.org>
-rw-r--r--app-admin/bitwarden-desktop-bin/Manifest1
-rw-r--r--app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2023.2.0.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-admin/bitwarden-desktop-bin/Manifest b/app-admin/bitwarden-desktop-bin/Manifest
index c4bfd3c087ed..2cec043ec63d 100644
--- a/app-admin/bitwarden-desktop-bin/Manifest
+++ b/app-admin/bitwarden-desktop-bin/Manifest
@@ -1,2 +1,3 @@
DIST Bitwarden-2022.12.0-amd64.deb 65434808 BLAKE2B 81e7f1b0d7a95fa08554fced72440d65c4fb5fb86371f4ce773904f53543a3586f56eb53d2a4f79034a475430d3b2926404a2bc178e49bb97999295100a6a352 SHA512 ca1fafe48b3dcbab8c2152ed84337c7ebd8cc1934f24d2eabf7ef65733c163e84fc9e49f8566cf2201ab557144e81360db8d8ee1883a92c275804d7c3ddf886b
DIST Bitwarden-2022.9.1-amd64.deb 64957370 BLAKE2B 05d1f206503b41ed2a118948b3bd74cb6418dde661f3e620644abe15108391fcd48e3211cb6ff48560eb6092dc2bd08620f3df24bb92de5b832301202456ecb9 SHA512 5907b58d4da1933809342f482f26833b4513e2b2d2a62a7f2ddec02e571069f3d0a5b509a57c4390f00677dd9c6a6164217e32a5911268da683ef94713345505
+DIST Bitwarden-2023.2.0-amd64.deb 70836086 BLAKE2B 84c9bfd58a0b5e1647f8bf6af8e9c0070bb940896161c58bbcf43af03109e6623d741dfe303af84fd2ed98e8c16f95ef9eaa3936b6c39c851d4960ba29d4554e SHA512 19cc12e85c2b4fdff2c52747fcea9cd888040c2d20faa0eaf81237d4ccbe4a0c4ed0df792c6c193768e33329561759357dc333fd05018a00e82bc71a4e8082e8
diff --git a/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2023.2.0.ebuild b/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2023.2.0.ebuild
new file mode 100644
index 000000000000..b6d1c4a5245a
--- /dev/null
+++ b/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2023.2.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg-utils
+
+MY_PN="Bitwarden"
+
+DESCRIPTION="Bitwarden password manager desktop client"
+HOMEPAGE="https://bitwarden.com/"
+SRC_URI="https://github.com/bitwarden/clients/releases/download/desktop-v${PV}/Bitwarden-${PV}-amd64.deb"
+S="${WORKDIR}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ || (
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ ( app-accessibility/at-spi2-atk dev-libs/atk )
+ )
+ app-crypt/libsecret
+ dev-libs/expat
+ dev-libs/glib
+ sys-libs/glibc
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libxshmfence
+ x11-libs/libXtst
+ x11-libs/pango
+"
+IDEPEND="
+ dev-util/desktop-file-utils
+ dev-util/gtk-update-icon-cache
+"
+
+QA_PREBUILT="
+ opt/Bitwarden/*.so*
+ opt/Bitwarden/bitwarden
+ opt/Bitwarden/chrome-sandbox
+ opt/Bitwarden/chrome_crashpad_handler
+"
+
+src_install() {
+ insinto /opt
+ doins -r opt/${MY_PN}
+ fperms 755 /opt/Bitwarden/bitwarden
+ fperms 4755 /opt/Bitwarden/chrome-sandbox
+
+ domenu usr/share/applications/bitwarden.desktop
+
+ local x
+ for x in 16 32 64 128 256 512; do
+ doicon -s ${x} usr/share/icons/hicolor/${x}*/*
+ done
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}