summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-22 00:28:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-22 18:05:55 +0200
commit77be775f9b731a24af9cc1013050d0ea22f1d540 (patch)
tree0cd89d5e0a2d2eb5fcbb926f068fb5951aac2b76
parentmedia-sound/qsynth: Update 9999, run default before eautoreconf (diff)
downloadgentoo-77be775f9b731a24af9cc1013050d0ea22f1d540.tar.gz
gentoo-77be775f9b731a24af9cc1013050d0ea22f1d540.tar.bz2
gentoo-77be775f9b731a24af9cc1013050d0ea22f1d540.zip
media-sound/qsynth: 0.6.3 version bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-0.6.3.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index 59e267c0362c..ec10b52bb77c 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1 +1,2 @@
DIST qsynth-0.6.2.tar.gz 383146 BLAKE2B 6e93a1d16dc57ce5cc180932eec049cbd62eb64d6667cbfc748c474fe2b751273ff50a94a5497f1d268e2d413831095bea92a2f086b417625f02fecf1bc6ec9d SHA512 6e6f5dc64c39ab18ad1a9e791376e0dcf6eea4882986b1723a5a2f7c53309ce166d443a198c62b33ac31ed3fc17100c3a4f8e3b1e474b70afcec0ffa7f1ffc08
+DIST qsynth-0.6.3.tar.gz 382990 BLAKE2B 37565c86b077602cd681b92aaea20d4aa07db1c4cf51d391562b5226ddde70dad0a3f641f0fcf54f35c6bb1a9e487a779c22237b0c8087666b7a2c1dea8a511e SHA512 7320a355b5fbb347b04b46fdfe86c13ab18b264cff09f2ed133e2b065febac27e58bd709eea284b4d0f98034059647ad6e9b97638fdd75edb1524fd3cf9f07a2
diff --git a/media-sound/qsynth/qsynth-0.6.3.ebuild b/media-sound/qsynth/qsynth-0.6.3.ebuild
new file mode 100644
index 000000000000..5cb416916d3d
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.6.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils xdg-utils
+
+DESCRIPTION="Qt application to control FluidSynth"
+HOMEPAGE="https://qsynth.sourceforge.io/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.4.0-qt5-tagging.patch" )
+
+src_configure() {
+ sed -e "/@gzip.*mandir)\/man1/d" -i Makefile.in || die
+ econf \
+ $(use_enable debug)
+
+ eqmake5 ${PN}.pro -o ${PN}.mak
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${D}/usr/share/applications/qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}