summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-26 09:22:13 +0100
committerSam James <sam@gentoo.org>2022-07-26 09:40:54 +0100
commit80b27ad743723ca12f1e92be6267a2496bfc25ea (patch)
treed9504aff9f76438880fbf3fdeb828c788f7be99b
parentdev-go/go-licenses: drop 0_pre20200511, 9999 (diff)
downloadgentoo-80b27ad743723ca12f1e92be6267a2496bfc25ea.tar.gz
gentoo-80b27ad743723ca12f1e92be6267a2496bfc25ea.tar.bz2
gentoo-80b27ad743723ca12f1e92be6267a2496bfc25ea.zip
dev-util/sh: new package, add 3.5.1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/sh/Manifest2
-rw-r--r--dev-util/sh/metadata.xml11
-rw-r--r--dev-util/sh/sh-3.5.1.ebuild30
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/sh/Manifest b/dev-util/sh/Manifest
new file mode 100644
index 000000000000..d74589817b91
--- /dev/null
+++ b/dev-util/sh/Manifest
@@ -0,0 +1,2 @@
+DIST sh-3.5.1-deps.tar.xz 3113476 BLAKE2B 0998ebeacdd7c882542eea25ad5ab3131211c686ac2ba8040b89897a60ab41ecea7fc0c45f6498eda56a4539550622e2693fed0a6a1ed5ca6af060c40a9aaf97 SHA512 b572f7334e04365d3d685ba8b87fff834fb9823e815152646659d66e92410cab03940b5a32f6eb0634c4a0cce34808d03849d8b97b17fdbec939b305b13878e9
+DIST sh-3.5.1.tar.gz 222608 BLAKE2B a81af092d0f8d0ee7c05240d816a99f044bce3e35d242a815a238a27893db5bfc320efc4a0237ca9ecfa0276e4687152c87f6e0170f5326e2d0a8604f94f6adb SHA512 fd1084921254b70376b3ac47b97e2108308252fa6bd23aff1e59aaefb45a7e01c1738a46ae6f4eb255ecade77fb9659fbc8184d2473e8e4f70e520757bad506d
diff --git a/dev-util/sh/metadata.xml b/dev-util/sh/metadata.xml
new file mode 100644
index 000000000000..1e811dcb7fc9
--- /dev/null
+++ b/dev-util/sh/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mvdan/sh</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/sh/sh-3.5.1.ebuild b/dev-util/sh/sh-3.5.1.ebuild
new file mode 100644
index 000000000000..f5098aea771b
--- /dev/null
+++ b/dev-util/sh/sh-3.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A shell parser, formatter, and interpreter with bash support"
+HOMEPAGE="https://github.com/mvdan/sh"
+SRC_URI="https://github.com/mvdan/sh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ # Not bothering with gosh for now as it's very new
+ # https://github.com/mvdan/sh#gosh
+ ego build ./cmd/shfmt
+}
+
+src_test() {
+ cd syntax || die
+ ego test -run=-
+}
+
+src_install() {
+ dobin shfmt
+}