summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-13 15:43:55 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-13 16:58:49 -0400
commita2733391f0da70270f62bc4c56742b2c7270d9ef (patch)
treee9054c4a940dc90b432c2625bb439ba51b1efc2f
parentdev-libs/xxhash: drop 0.7.3, 0.8.0 (diff)
downloadgentoo-a2733391f0da70270f62bc4c56742b2c7270d9ef.tar.gz
gentoo-a2733391f0da70270f62bc4c56742b2c7270d9ef.tar.bz2
gentoo-a2733391f0da70270f62bc4c56742b2c7270d9ef.zip
dev-libs/xxhash: add 0.8.2, EAPI=8, enable multilib
multilib can be used by multilib libplacebo which is itself used by multilib ffmpeg and so on. Unfortunately haven't looked at enabling dispatch, would essentially need to compile with different sanitized FLAGS from a quick look at the files which needs closer attention. Also drop IUSE=static-libs, unsure if someone actually wanted this but nothing in-tree seems to. Closes: https://bugs.gentoo.org/912419 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-libs/xxhash/Manifest1
-rw-r--r--dev-libs/xxhash/xxhash-0.8.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/xxhash/Manifest b/dev-libs/xxhash/Manifest
index 7b575b7eb166..be3b82a468e2 100644
--- a/dev-libs/xxhash/Manifest
+++ b/dev-libs/xxhash/Manifest
@@ -1 +1,2 @@
DIST xxhash-0.8.1.tar.gz 171552 BLAKE2B c0efc1aabf68130d7028a6e43fb04826de4ec485bfb5e915bd9dad823149b970f964784e14c35babd46b9811b961ce3d0be49feb1640e00780decf037427f5fc SHA512 12feedd6a1859ef55e27218dbd6dcceccbb5a4da34cd80240d2f7d44cd246c7afdeb59830c2d5b90189bb5159293532208bf5bb622250102e12d6e1bad14a193
+DIST xxhash-0.8.2.tar.gz 1141188 BLAKE2B 735408256240760778fa516e01bed428f04837eb4e059c512e924f13e4a96db6cacbbefb04dea65a37b0f25b52cf13c4927a6e7870dc8c0d45b1b955d4ba3da1 SHA512 3e3eef21432fe88bc4dd9940ccad0308fdea3537b06fa5ac0e74c1bde53413dff29c8b3fc617a8a42b9ce88fcf213311d338a31b1ce73b3729342c9e68f06c78
diff --git a/dev-libs/xxhash/xxhash-0.8.2.ebuild b/dev-libs/xxhash/xxhash-0.8.2.ebuild
new file mode 100644
index 000000000000..3645cde42506
--- /dev/null
+++ b/dev-libs/xxhash/xxhash-0.8.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal toolchain-funcs
+
+DESCRIPTION="Extremely fast non-cryptographic hash algorithm"
+HOMEPAGE="https://xxhash.com/"
+SRC_URI="https://github.com/Cyan4973/xxHash/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/xxHash-${PV}
+
+LICENSE="BSD-2 GPL-2+"
+# https://abi-laboratory.pro/tracker/timeline/xxhash
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+src_prepare() {
+ default
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+multilib_src_test() {
+ emake CC="$(tc-getCC)" check
+}
+
+multilib_src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ LIBDIR="${EPREFIX}"/usr/$(get_libdir)
+ )
+
+ emake "${emakeargs[@]}" install
+ einstalldocs
+
+ rm "${ED}"/usr/$(get_libdir)/libxxhash.a || die
+}