summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-13 04:01:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-13 04:12:11 +0200
commite13fe9ec8d561a8ebee2069b6c6d35c393d95f47 (patch)
tree3eeb470e68702a23a549b77babf06af651bfb66e
parentdev-python/pywlroots: Bump to 0.16.9 (diff)
downloadgentoo-e13fe9ec8d561a8ebee2069b6c6d35c393d95f47.tar.gz
gentoo-e13fe9ec8d561a8ebee2069b6c6d35c393d95f47.tar.bz2
gentoo-e13fe9ec8d561a8ebee2069b6c6d35c393d95f47.zip
dev-python/pywlroots: Bump to 0.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pywlroots/Manifest1
-rw-r--r--dev-python/pywlroots/pywlroots-0.17.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pywlroots/Manifest b/dev-python/pywlroots/Manifest
index 0689f608b153..439a658cb369 100644
--- a/dev-python/pywlroots/Manifest
+++ b/dev-python/pywlroots/Manifest
@@ -2,3 +2,4 @@ DIST pywlroots-0.15.24.gh.tar.gz 85570 BLAKE2B 0c7ba0be6159152488785298028bb1fee
DIST pywlroots-0.16.7.tar.gz 98542 BLAKE2B bcc20d31e4423c6f486f6bcbfecb1db1995cc3d58e98205f63468b4b93b3f386f67ff22e8a99cd419b7b31f7c0287a61f8c4e1fed6e7af525244e94895ba55d6 SHA512 05e75f70ca6e9fcf7cfd18fb55411fbf3ef9d0b95d11afdab0ad95f2016623ac4e097b600e3d7a6f880be0edc6a1ccfaa48364ec02bd3c46c44f7c0de3fe96ac
DIST pywlroots-0.16.8.tar.gz 100267 BLAKE2B 969f528a849a5b2b3c5c9147971c1fa4e105d894c3086e0283877cdedb8f1535632fd8554adfda2419881a0a0efb9bbbba420950991f36746a66b543052f8301 SHA512 2b374ce77d35106830e8de8d96bb3572ff3853ce7a431e280580144ffc530531df5a79f54e5064d6186b7cc660a97dfb5d954155c71d8e70109d50206d96c597
DIST pywlroots-0.16.9.tar.gz 100390 BLAKE2B 139a7514ee503d883519dbd157a6ec75024ad8ac5d8b07b518831f94b04d2e28bba62a58351bc896a306533b4e88deb251caf00c48e3be7877d0f6ce7e833036 SHA512 b7fea09d1b2eb6ff443e712222d63693ad440b2dc7b22dc49ec9b166ae45038662f0f68ca15db5e8bf8776b3ceb880f846341883bf99dd783f323bd46f6a3ac6
+DIST pywlroots-0.17.0.tar.gz 99439 BLAKE2B 0f4153e5d4e7786d52d2a66614c4c92d29d0ef57be74ce8e7b23ed244c361a551b84606493296b99b4b1f48f5c862911f48aa32f3e7d5bd1c0fcedcfb1240474 SHA512 20b93845f26f1942bc111d12de24acc17af24cd70abd644a66a4b43e3622fa2cb9323c7dc846a5708c5cb63631e77020350231a67d3b6702ac5882fcd31411df
diff --git a/dev-python/pywlroots/pywlroots-0.17.0.ebuild b/dev-python/pywlroots/pywlroots-0.17.0.ebuild
new file mode 100644
index 000000000000..9a4044ba719c
--- /dev/null
+++ b/dev-python/pywlroots/pywlroots-0.17.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python binding to the wlroots library using cffi"
+HOMEPAGE="
+ https://github.com/flacjacket/pywlroots/
+ https://pypi.org/project/pywlroots/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="X"
+
+# See README for wlroots dep
+DEPEND="
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ >=dev-python/pywayland-0.4.14[${PYTHON_USEDEP}]
+ >=dev-python/xkbcommon-0.2[${PYTHON_USEDEP}]
+ =gui-libs/wlroots-$(ver_cut 1-2)*:=[X?]
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.24-no-import-version-check.patch
+ )
+
+ # override automagic detection and caching that's completely broken
+ # by design; https://github.com/flacjacket/pywlroots/issues/132
+ cat > wlroots/_build.py <<-EOF || die
+ has_xwayland = $(usex X True False)
+ EOF
+ sed -e "s:return.*has_xwayland$:return $(usex X True False):" \
+ -i wlroots/ffi_build.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ rm -rf wlroots || die
+ epytest
+}