summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-11-20 09:14:57 -0500
committerYixun Lan <dlan@gentoo.org>2024-11-20 21:28:17 +0000
commite5feb0d917a8a915fc77a718aab2f692ea8ba117 (patch)
tree2835bfc39cbef2ac57f99b6a6a33f1b4246f0d86
parentnet-dns/knot-resolver: drop 5.7.1 (diff)
downloadgentoo-e5feb0d917a8a915fc77a718aab2f692ea8ba117.tar.gz
gentoo-e5feb0d917a8a915fc77a718aab2f692ea8ba117.tar.bz2
gentoo-e5feb0d917a8a915fc77a718aab2f692ea8ba117.zip
gui-wm/hyprland: add 0.45.2
Closes: https://github.com/gentoo/gentoo/pull/39383 Signed-off-by: Julien Roy <julien@jroy.ca> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--gui-wm/hyprland/Manifest1
-rw-r--r--gui-wm/hyprland/hyprland-0.45.2.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/gui-wm/hyprland/Manifest b/gui-wm/hyprland/Manifest
index 792d9a47d0bc..e6df68bd6fd5 100644
--- a/gui-wm/hyprland/Manifest
+++ b/gui-wm/hyprland/Manifest
@@ -2,3 +2,4 @@ DIST hyprland-0.42.0.gh.tar.gz 54225438 BLAKE2B a947289c5568408d71383034a290f114
DIST hyprland-0.44.1.gh.tar.gz 54398098 BLAKE2B ab5b52fa27591ad1f6db524663a85c2eb3f1137c8a55d6eaad9a41837fe057d6a92a75fb3bec930693a10311e3b82488ff94af86f4c2d58557879bffea02426f SHA512 2ffa16a180ec9f9e6b20481b0724e24524a499f7a224f72598426a6630c675632f2447a2f7dfd4609e8da9a86dda7919e40002a91dc917af2541e639fb4d542d
DIST hyprland-0.45.0.gh.tar.gz 54409358 BLAKE2B 9744b525d2128d3723e42267620fa0b2e593eea13c564c3f2e38264dda97eacc422d44dc3c86b79deadbc785ba6f121148206ca47fb7f30b07722c2ef448199e SHA512 06b0d3eee9831e2f1dfa5e93c12cea82d3bcfa80685cfacac8f076a4467848c77b5bb06d8c389046588c1cc2340a2405c22b09794fec37bae4a9e3697a0875a2
DIST hyprland-0.45.1.gh.tar.gz 54410237 BLAKE2B 789df658e9705ece110e7c8b693a4dcc839e906a763d1ae16d8607b167bd3bbf60f301bda9ae1b202bd4bae51a1fe9f5ae9bf8c0dcdb5296024f469d7acb91b7 SHA512 dd9902fba8658f197ad27bf1e1597d6fce2b2a9a4d1dde48721ef162a89025e923dc8847a525eb444968d590c52a9a3bbd4e35d3781639d0b3f1d20b61920a43
+DIST hyprland-0.45.2.gh.tar.gz 54410230 BLAKE2B 06a45c12b2655bb6a7eccda8948858a07b90b08d534de254c7a05facf6822869143ebb1cd55e3d42a6c51cee05717e89ec2cfb820c6d2901c4cd012c5fda9d5b SHA512 3159f0bd2153602a9d3938dc1e82a6b765bbaf672755b68a55ea863c5cb537c6811d7485f4451cfabce2ec8338ccb4b8eafbceb5632d23cba62f09c9e2fa3864
diff --git a/gui-wm/hyprland/hyprland-0.45.2.ebuild b/gui-wm/hyprland/hyprland-0.45.2.ebuild
new file mode 100644
index 000000000000..cab0caee888f
--- /dev/null
+++ b/gui-wm/hyprland/hyprland-0.45.2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs
+
+DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
+HOMEPAGE="https://github.com/hyprwm/Hyprland"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-source"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="X legacy-renderer systemd"
+
+# hyprpm (hyprland plugin manager) requires the dependencies at runtime
+# so that it can clone, compile and install plugins.
+HYPRPM_RDEPEND="
+ app-alternatives/ninja
+ >=dev-build/cmake-3.30
+ dev-build/meson
+ dev-vcs/git
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${HYPRPM_RDEPEND}
+ dev-cpp/tomlplusplus
+ dev-libs/glib:2
+ dev-libs/libinput
+ >=dev-libs/udis86-1.7.2
+ >=dev-libs/wayland-1.22.90
+ >=gui-libs/aquamarine-0.4.2
+ >=gui-libs/hyprcursor-0.1.9
+ media-libs/libglvnd
+ x11-libs/cairo
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ x11-libs/libXcursor
+ X? (
+ x11-libs/libxcb:0=
+ x11-base/xwayland
+ x11-libs/xcb-util-errors
+ x11-libs/xcb-util-wm
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/hyprland-protocols-0.4
+ >=dev-libs/hyprlang-0.3.2
+ >=dev-libs/wayland-protocols-1.36
+ >=gui-libs/hyprutils-0.2.3
+"
+BDEPEND="
+ || ( >=sys-devel/gcc-14:* >=sys-devel/clang-18:* )
+ app-misc/jq
+ dev-build/cmake
+ >=dev-util/hyprwayland-scanner-0.3.10
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ if tc-is-gcc && ver_test $(gcc-version) -lt 14 ; then
+ eerror "Hyprland requires >=sys-devel/gcc-14 to build"
+ eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
+ die "GCC version is too old to compile Hyprland!"
+ elif tc-is-clang && ver_test $(clang-version) -lt 18 ; then
+ eerror "Hyprland requires >=sys-devel/clang-18 to build"
+ eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ die "Clang version is too old to compile Hyprland!"
+ fi
+}
+
+src_prepare() {
+ # skip version.h
+ sed -i -e "s|scripts/generateVersion.sh|echo|g" meson.build || die
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature legacy-renderer legacy_renderer)
+ $(meson_feature systemd)
+ $(meson_feature X xwayland)
+ )
+
+ meson_src_configure
+}