summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-08 23:24:54 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-09 01:07:10 +0200
commitf307ade32c2ee425c4929808e17bb9a01c3e5ec0 (patch)
treee55758db087180f1e54753d937b2d8fe8bcfa426
parentmedia-gfx/curtail: drop old 1.9.1 (diff)
downloadgentoo-f307ade32c2ee425c4929808e17bb9a01c3e5ec0.tar.gz
gentoo-f307ade32c2ee425c4929808e17bb9a01c3e5ec0.tar.bz2
gentoo-f307ade32c2ee425c4929808e17bb9a01c3e5ec0.zip
media-gfx/curtail: bump to 1.11.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--media-gfx/curtail/Manifest1
-rw-r--r--media-gfx/curtail/curtail-1.11.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/curtail/Manifest b/media-gfx/curtail/Manifest
index 276195371b00..d3c90a983d50 100644
--- a/media-gfx/curtail/Manifest
+++ b/media-gfx/curtail/Manifest
@@ -1 +1,2 @@
DIST curtail-1.10.0.tar.gz 205428 BLAKE2B 7a9d1c56542648cd1c4c6fe1355276896bea96a8f054d03c2e4a174e392867db05c3a6548897d31f078b2416eac8b3695cafd3977236f0b66fd10f3020e35d3a SHA512 6bd76b4cefd693199e25db112e90acaa990d2a8dbc2016bd9d55e8d1857bd9c6e94f9164691855231afeff65ae3b070c646a8dc8b446591a08509683dd4a9fb7
+DIST curtail-1.11.0.tar.gz 208900 BLAKE2B b1f9fdff8d974ba20345100b24b783c72f241e8612c28468eec424dbe8781affd88523953299a7f5d90575db7c6727e6fa7a4a1e7439dcb94c47806fb77412cf SHA512 eb5bf7400fa97d14d67a0eecaeee2c3cc6b3407b882a5ae42bb517df98429997fe4448a7852c55a39177f035764e4e544f13fb89d7a55e5b6a01a549acc71ecb
diff --git a/media-gfx/curtail/curtail-1.11.0.ebuild b/media-gfx/curtail/curtail-1.11.0.ebuild
new file mode 100644
index 000000000000..8db3728be1ae
--- /dev/null
+++ b/media-gfx/curtail/curtail-1.11.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Image compressor, supporting PNG, JPEG and WebP"
+HOMEPAGE="https://github.com/Huluti/Curtail/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Huluti/${PN^}.git"
+else
+ SRC_URI="https://github.com/Huluti/${PN^}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${P^}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test" # Just desktop / schema / appstream file validation (fails).
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+"
+RDEPEND+="
+ >=gui-libs/libadwaita-1.3.1
+ media-gfx/jpegoptim
+ media-gfx/oxipng
+ media-gfx/pngquant
+ media-libs/libwebp
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_prepare() {
+ sed -i "s|@PYTHON@|${PYTHON}|" "${S}/src/${PN}.in" || die
+
+ default
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}