summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-07-31 17:04:08 +0200
committerSebastian Pipping <sping@gentoo.org>2019-07-31 17:05:10 +0200
commitd98a5aa7340700f7bad5fcc7f5824bf2fcf770a9 (patch)
treee2c9cd2d910439a5116c6da1c76d0693bc639b83 /app-admin/checksec/checksec-2.1.0.ebuild
parentnet-libs/libssh: alpha stable wrt bug #691110 (diff)
downloadgentoo-d98a5aa7340700f7bad5fcc7f5824bf2fcf770a9.tar.gz
gentoo-d98a5aa7340700f7bad5fcc7f5824bf2fcf770a9.tar.bz2
gentoo-d98a5aa7340700f7bad5fcc7f5824bf2fcf770a9.zip
app-admin/checksec: 2.1.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.68, Repoman-2.3.16
Diffstat (limited to 'app-admin/checksec/checksec-2.1.0.ebuild')
-rw-r--r--app-admin/checksec/checksec-2.1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/checksec/checksec-2.1.0.ebuild b/app-admin/checksec/checksec-2.1.0.ebuild
new file mode 100644
index 000000000000..3dd38365d970
--- /dev/null
+++ b/app-admin/checksec/checksec-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN=${PN}.sh
+DESCRIPTION="Tool to check properties of executables (e.g. ASLR/PIE, RELRO, PaX, Canaries)"
+HOMEPAGE="https://github.com/slimm609/checksec.sh"
+SRC_URI="https://github.com/slimm609/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+DOCS=( ChangeLog README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.2-path.patch
+)
+
+src_prepare() {
+ sed 's,^pkg_release=false,pkg_release=true,' -i ${PN} || die
+ default
+}
+
+src_install() {
+ default
+
+ doman extras/man/*
+
+ insinto /usr/share/zsh/site-functions
+ doins extras/zsh/_${PN}
+
+ dobin ${PN}
+}