summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/reportmagic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/reportmagic')
-rw-r--r--app-admin/reportmagic/Manifest1
-rw-r--r--app-admin/reportmagic/metadata.xml11
-rw-r--r--app-admin/reportmagic/reportmagic-2.21.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/app-admin/reportmagic/Manifest b/app-admin/reportmagic/Manifest
new file mode 100644
index 000000000000..258dedbc68f5
--- /dev/null
+++ b/app-admin/reportmagic/Manifest
@@ -0,0 +1 @@
+DIST rmagic-2.21.tar.gz 451179 SHA256 a3e9276634e25cee08c7a309a98a61eec6a5af15ca8a75653b40b98ead35e69f SHA512 ed9f4e6f8d6160afbe138125c4cb65010a08b95390117ebf07ccde289ff42b78664b1fe677e23f46a221d153889f807c545329936829fceeae4690b00732a637 WHIRLPOOL f3c3a0e0d00deaaeae9d4c1b49aeb533838585f7596cc1ffa197da8e9762140f8b3ed73f56f226241b96c398c739a7d8410b47c27fcca59cc22a85393cf022bf
diff --git a/app-admin/reportmagic/metadata.xml b/app-admin/reportmagic/metadata.xml
new file mode 100644
index 000000000000..89915e672570
--- /dev/null
+++ b/app-admin/reportmagic/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ A report generating applicaton from web site log files.
+ </longdescription>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-admin/reportmagic/reportmagic-2.21.ebuild b/app-admin/reportmagic/reportmagic-2.21.ebuild
new file mode 100644
index 000000000000..cc9b2c952bc8
--- /dev/null
+++ b/app-admin/reportmagic/reportmagic-2.21.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Makes usable statistics from your web site log file analysis"
+HOMEPAGE="http://www.reportmagic.org/"
+SRC_URI="http://www.reportmagic.org/rmagic-${PV}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="x86 ppc amd64"
+IUSE="truetype"
+
+DEPEND="sys-libs/zlib
+ media-libs/libpng
+ media-libs/gd
+ truetype? ( media-libs/freetype )
+ virtual/jpeg
+ dev-perl/GD
+ dev-perl/Config-IniFiles
+ virtual/perl-File-Spec
+ dev-perl/HTML-Tagset
+ dev-perl/HTML-Parser
+ dev-perl/GDGraph
+ virtual/perl-File-Temp
+ dev-perl/GD-Graph3d"
+
+S="${WORKDIR}/rmagic-${PV}"
+
+src_unpack() {
+ unpack ${A} ; cd "${S}"
+
+ sed -i \
+ -e "s:^\$DEST.*:\$DEST='${D}/usr/share/reportmagic';:g" \
+ -e "s:^\$DOC.*:\$DOC='${D}/usr/share/doc/${PF}';:g" \
+ Install.PL \
+ || die "sed failed"
+}
+
+src_install() {
+ perl Install.PL -no_modules
+}