summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-06-09 00:28:00 +0200
committerSebastian Pipping <sping@gentoo.org>2024-06-09 00:28:00 +0200
commitf5630daae99a227c9a91c755fe94d1e44fe510af (patch)
treeb20dd21c4865183385e25f10ac7d635dff4e4710 /app-admin/ttyplot
parentapp-admin/ttyplot: Drop old (diff)
downloadgentoo-f5630daae99a227c9a91c755fe94d1e44fe510af.tar.gz
gentoo-f5630daae99a227c9a91c755fe94d1e44fe510af.tar.bz2
gentoo-f5630daae99a227c9a91c755fe94d1e44fe510af.zip
app-admin/ttyplot: 1.6.4
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'app-admin/ttyplot')
-rw-r--r--app-admin/ttyplot/Manifest1
-rw-r--r--app-admin/ttyplot/ttyplot-1.6.4.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/ttyplot/Manifest b/app-admin/ttyplot/Manifest
index 7849fcdad20c..7fa7aaa40eaa 100644
--- a/app-admin/ttyplot/Manifest
+++ b/app-admin/ttyplot/Manifest
@@ -1 +1,2 @@
DIST ttyplot-1.6.2.gh.tar.gz 56277 BLAKE2B c7a818a69774fc7c5f6b498e5bf2f9c3ec644dc23d54daf59adaf13962f614c23918ca1d84614e27c60e75d1b98b3eb3c548dc14b59b539acceb3327dafabe0c SHA512 7ede447667a0a8f4b164a2a409e1264c36c95c22eeeda348c894678cb8d7209e742bb90f48a8a5260dd457ae7ff0a090a7d8b7eb25b20e20ada575e00cc4eb0b
+DIST ttyplot-1.6.4.gh.tar.gz 56541 BLAKE2B b05fffd2a7903ec94d516c7e970db4dd2dd90ac2568c6c3e3b6608e40ab65a18ac6a9a9693e189328bfebdd120fb50efd8bedcb260329d5ad28d0c7a81c390dd SHA512 51d8cc7dfa281f66e92b0f508f9db413869bb559aa6d1f4a54eb658f3564e2552b622e8667587bbe9e7c85063b03704a03e8eb004b979c68bf874453b5c3cbb5
diff --git a/app-admin/ttyplot/ttyplot-1.6.4.ebuild b/app-admin/ttyplot/ttyplot-1.6.4.ebuild
new file mode 100644
index 000000000000..a0e31d253379
--- /dev/null
+++ b/app-admin/ttyplot/ttyplot-1.6.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Realtime plotting utility with data input from stdin"
+HOMEPAGE="https://github.com/tenox7/ttyplot"
+SRC_URI="https://github.com/tenox7/ttyplot/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/pkgconfig"
+DEPEND="${RDEPEND}
+ sys-libs/ncurses[tinfo]"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ local args=(
+ PREFIX=/usr
+ MANPREFIX=/usr/share/man
+ DESTDIR="${D}"
+ )
+ emake "${args[@]}" install
+}