summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-02 11:27:59 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-06-20 15:59:19 +0200
commit27b87428a89f8e58a83a751fef88098b217d5752 (patch)
tree7edd3915a854363666b124965bfd977ec653093a /app-admin/xstow
parentnet-libs/nodejs: drop 18.20.2, 20.12.2, 20.13.1, 22.1.0, 22.2.0 (diff)
downloadgentoo-27b87428a89f8e58a83a751fef88098b217d5752.tar.gz
gentoo-27b87428a89f8e58a83a751fef88098b217d5752.tar.bz2
gentoo-27b87428a89f8e58a83a751fef88098b217d5752.zip
app-admin/xstow: add 1.1.1
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/36967 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-admin/xstow')
-rw-r--r--app-admin/xstow/Manifest1
-rw-r--r--app-admin/xstow/xstow-1.1.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/xstow/Manifest b/app-admin/xstow/Manifest
index 2f92a34ddb06..21811777c9b8 100644
--- a/app-admin/xstow/Manifest
+++ b/app-admin/xstow/Manifest
@@ -1 +1,2 @@
DIST xstow-1.1.0.tar.bz2 187761 BLAKE2B ed3822e638aedf8900a3baba62a5af9de9d7b98dcdf27ca81a6898353b9f5c7f767ec7d8e68ead4d5ef318af5a6eda2b1cc68a5c80a6a8ad2b9c8adf03ae3377 SHA512 30f2e0be0c2aba668b4cc781fe69ac74c2460cc681c6b47a55ee66af5c0f2ac14dee9fe2e95a288ce06059378407a2b99d2156430a5a6dcbf06def793f579015
+DIST xstow-1.1.1.tar.bz2 188334 BLAKE2B 13b079b4c0bdfc68837d3674eb64852d6c8bd341541c927703eed7e302ce36328bc814c618972365b60bd7562a4a2398c6a881a0a42c5778523197e41cfde7df SHA512 86154bd562e1dcb068a2c766a849975a4e6c9c343d89d47f8dd339a03b73aceb2dfb8523e2bc40df3ceb673a1a9f7991737e982c0c1a2cc0bd9fcdf8fd7c3113
diff --git a/app-admin/xstow/xstow-1.1.1.ebuild b/app-admin/xstow/xstow-1.1.1.ebuild
new file mode 100644
index 000000000000..d6dcfa3ad50d
--- /dev/null
+++ b/app-admin/xstow/xstow-1.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Replacement for GNU stow with extensions"
+HOMEPAGE="https://github.com/majorkingleo/xstow"
+SRC_URI="https://github.com/majorkingleo/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ncurses"
+
+DEPEND="ncurses? ( sys-libs/ncurses:= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with ncurses curses)
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+ einstalldocs
+
+ # Create new STOWDIR
+ keepdir /var/lib/xstow
+
+ # Install env.d file to add STOWDIR to PATH and LDPATH
+ doenvd "${FILESDIR}"/99xstow
+}
+
+pkg_postinst() {
+ elog "We now recommend that you use /var/lib/xstow as your STOWDIR"
+ elog "instead of /usr/local in order to avoid conflicts with the"
+ elog "symlink from /usr/lib64 -> /usr/lib. See Bug 246264"
+ elog "(regarding app-admin/stow, equally applicable to XStow) for"
+ elog "more details on this change."
+ elog "For your convenience, PATH has been updated to include"
+ elog "/var/lib/bin."
+}