summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-19 06:52:05 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-19 08:56:22 +0100
commit33c660b2f5dc8f7e31b276e8f4b8353144526b03 (patch)
tree4d8074e66f8f6bbfc01ab3ba23b213567f4ba959 /app-admin
parentdev-python/boto3: Bump to 1.36.23 (diff)
downloadgentoo-33c660b2f5dc8f7e31b276e8f4b8353144526b03.tar.gz
gentoo-33c660b2f5dc8f7e31b276e8f4b8353144526b03.tar.bz2
gentoo-33c660b2f5dc8f7e31b276e8f4b8353144526b03.zip
app-admin/awscli: Bump to 1.37.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.37.23.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 705cba6acff0..ecd039764108 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,3 +2,4 @@ DIST aws-cli-1.37.11.gh.tar.gz 2900600 BLAKE2B eed7e50f8b481fa3f7ff1cbb4d6c95354
DIST aws-cli-1.37.16.gh.tar.gz 2903703 BLAKE2B 0d3333bef89222e9e84de2c469a98c6fd19177ba6c7e69278e43f459f1909d67e07cdc4150189dd3fd2ce1573ae43a22c944d172738de6102ecf7c7ea00404cf SHA512 d9916ecfedd8bd9086608b6350f95374efad96f3af6adc8b372a254021e4b9f00c43a7c5759cd74f20082f60806fc6eb13d8daf7569fad303995f6d180958cb9
DIST aws-cli-1.37.21.gh.tar.gz 2907762 BLAKE2B e42e9aed28ef3cee1b83f2e57f90ce81a9894bc23a960fef487096ce8b8bab16d23121658aed0547070919ae78a0476176f9517d583a84be90bb016c7cdd9bf7 SHA512 3c7b347627b799d7a3edc7a8cae3d6110ec3cc5bfcdecc247876135faebc2235546a514afbdaf95fec50cfe787ca30b125cae7a8e7be84134d83493a0f869b1a
DIST aws-cli-1.37.22.gh.tar.gz 2907598 BLAKE2B 00555a7fb5bbd4c527de2be1b0dc17b0de23e0aed9f9de8ef584e427632bb30da411b4e7d7a2deeb51c768dad00a3463542c7eac302080dc94b024d6e71c1088 SHA512 886ccbfe6536312129b0059f26eb81d0d3e334014740516f33c3b648cd1bb3e41482c99bb10639fb3e7e84d730d7dcb698500b65536ee9a9c7f07267d4e82fd6
+DIST aws-cli-1.37.23.gh.tar.gz 2907789 BLAKE2B d24999f8f416f2917bb841edda4a5827124bd51c0a421fcc658e1d526c35ea4177418351c3fc0c5d3908d65cc5b3b1e1e06f1c72985829600b3d405760f68eb8 SHA512 d45be9e18a48d4d7692ad2ab58c67571b083580e582c232f4e65eae6ca63e71b37f3f887b192589e5c74d78b4e7a22b813f866ceca8b13bbb1b191bef1a17377
diff --git a/app-admin/awscli/awscli-1.37.23.ebuild b/app-admin/awscli/awscli-1.37.23.ebuild
new file mode 100644
index 000000000000..4a8e0ae852e0
--- /dev/null
+++ b/app-admin/awscli/awscli-1.37.23.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.11.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}