summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-16 10:48:26 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-16 10:48:26 -0600
commit41ede72137c65ed53e69d923194eab31f3521c17 (patch)
treeec9e528718529c4deb77362115e48efad16467cf /app-admin
parentapp-emulation/virtualbox-guest-additions: Don't remove missing patch (diff)
downloadgentoo-41ede72137c65ed53e69d923194eab31f3521c17.tar.gz
gentoo-41ede72137c65ed53e69d923194eab31f3521c17.tar.bz2
gentoo-41ede72137c65ed53e69d923194eab31f3521c17.zip
app-admin/ansible: 2.8.8 and 2.9.3
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest2
-rw-r--r--app-admin/ansible/ansible-2.8.8.ebuild72
-rw-r--r--app-admin/ansible/ansible-2.9.3.ebuild68
3 files changed, 142 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index a3e6abd067af..2a03fc551f08 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,3 +1,5 @@
DIST ansible-2.7.15.tar.gz 10205890 BLAKE2B 30b0c83ad646cdcd918472be4512ee8cf00e966b9c7ed0431bcf915e858dae6aeb26cdff4eee5d480b751a4c33f30c2b213d8bc67d17bc8774c5ca2bcf897632 SHA512 7140fdb80456f5dd9f34226a9f38ce567ad13e4cd6b4058ae22012867554c9ed19e3cfa0ae7e745bf56d109fbe8dde8e264efce2f537b5bdae48cf606ee38f52
DIST ansible-2.8.7.tar.gz 12697144 BLAKE2B f88225b358ff9fad352c04a053100c5aa612f54ba7ad8e3a700d61e030fd0b5850055b83861d3ad76e614d3e786a2ed719f63b7f452ce24d7e27d79d386b8eed SHA512 166009780c8bb5b35beb9604412d4e5e3874e13b04f3ce694d726dc5bfb064f73a17ec3c814c8a67e28d57e7c327276b6cb66a9a0dba7138d702427ec13b4de3
+DIST ansible-2.8.8.tar.gz 12703583 BLAKE2B 0352646b495514d5a7a88fcd8e8437ef323f6d754f4704923b357c0f11c47932a2671a342e24f2de88479436f6f36664dbb0b26ee46fa98bc2d53d4f681595d0 SHA512 fb7705f3d0b8c0ee87d2954cccb7d00e12851693bbe995c062316577f66488f48d8180f11c8d87e025f4082a48ec27f25cb877be4c0ce96ed39951360e8679bd
DIST ansible-2.9.2.tar.gz 14157188 BLAKE2B 4c1207bd43f7797d8d9cb1d4612e866eebbf8c19ee060cf1eb7daa68415be5d7718c79d756454648e66a13434eacba6a07c8de31c4ec4b12e0474563d8844e46 SHA512 522dd84af9493ceafd95ff0fc806a671f3d1f10d0ca074ef41875eb966d39e64b834e0b98a35d81d9d9d96efef8069db604c8080ce8cbb1ce2e8b13bf5c30a6a
+DIST ansible-2.9.3.tar.gz 14170666 BLAKE2B bb27d249e2390888ee3c28fdb48c1ceff346d2903089c70b451f793742238498aed7c33be056cce9790f44f5cdb74b5020b6decf4f1242904bd9c8f7b5077ea0 SHA512 02cfa2c7c43506dc602e92aed66c920243222b82bc4852f1a4d786cd3ff26fe17eda18d35ac7301cd9bf26366df9b18776e2a27e8d54fc92c3128f52ec7f58e8
diff --git a/app-admin/ansible/ansible-2.8.8.ebuild b/app-admin/ansible/ansible-2.8.8.ebuild
new file mode 100644
index 000000000000..feb3f71a3ac7
--- /dev/null
+++ b/app-admin/ansible/ansible-2.8.8.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="doc test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_prepare_all() {
+ rm -fv MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ dodoc -r examples
+}
diff --git a/app-admin/ansible/ansible-2.9.3.ebuild b/app-admin/ansible/ansible-2.9.3.ebuild
new file mode 100644
index 000000000000..87aa8f15ecba
--- /dev/null
+++ b/app-admin/ansible/ansible-2.9.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="doc test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ dodoc -r examples
+}