summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2025-02-08 08:58:13 +0100
committerPetr Vaněk <arkamar@gentoo.org>2025-02-08 09:02:47 +0100
commit8209e0743d12393b6f434c29345bd16d039663df (patch)
tree15505617cb74f23da07a8f056916d7eecee80e42 /app-admin
parentwww-client/firefox: drop versions (diff)
downloadgentoo-8209e0743d12393b6f434c29345bd16d039663df.tar.gz
gentoo-8209e0743d12393b6f434c29345bd16d039663df.tar.bz2
gentoo-8209e0743d12393b6f434c29345bd16d039663df.zip
app-admin/entr: add 5.7
This release contains a fix [1], which should fix the bug 894538. [1] https://github.com/eradman/entr/pull/152 Closes: https://bugs.gentoo.org/894538 Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/entr/Manifest1
-rw-r--r--app-admin/entr/entr-5.7.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/entr/Manifest b/app-admin/entr/Manifest
index 42fe9bdc0250..a222d65f1747 100644
--- a/app-admin/entr/Manifest
+++ b/app-admin/entr/Manifest
@@ -1 +1,2 @@
DIST entr-5.6.tar.gz 23370 BLAKE2B 52b2e2d49d550c7ba82199cc70500598c50809136bc9bed881174ab59806802ac09cf7ff32f0476eeb66ee9fdb87bef72dbf28bfd4495f0301ee80809800dbfa SHA512 9c65449b6fd7e172fde23a6d4d776b6fdbcec210ef54234db0af056e481acd11f53f9b25432a278435943bd998be734fcd997b5debdcace58112ac99d103f653
+DIST entr-5.7.tar.gz 23587 BLAKE2B 497ac54042fd6d54f7c0f4401e2038d1f0f8e55277efb54389cd9c9635d2caf77e80d042456ac06cfe937ec88111cdebaaf8f6133cdddadcdb65d11442b9fe82 SHA512 a267fdc3a9aeb84823e14167a7aed32d682d200e72409f896e95aea3cb22e5185e1ee1c49726435d66953baae6444d49111e0c6a0af66895bdef0fccd3320446
diff --git a/app-admin/entr/entr-5.7.ebuild b/app-admin/entr/entr-5.7.ebuild
new file mode 100644
index 000000000000..7a4e050a9262
--- /dev/null
+++ b/app-admin/entr/entr-5.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="
+ https://eradman.com/entrproject/
+ https://github.com/eradman/entr
+"
+SRC_URI="https://eradman.com/entrproject/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-alternatives/awk[gawk]
+ app-editors/vim
+ app-misc/tmux
+ dev-vcs/git
+ sys-apps/file
+ )
+"
+
+src_configure() {
+ tc-export CC
+ export PREFIX="${EPREFIX}/usr"
+ export SHELL="${BROOT}/bin/bash"
+ export TMUX_TMPDIR="${T}"
+
+ edo ./configure
+}