summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-25 04:14:09 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-25 04:14:09 +0200
commita133cca44452ce79be6f7d19885eafb2b4d89542 (patch)
tree26ab65a3bb094f17575f87b65653908ce43c3a36 /app-admin
parentdev-python/boto3: Bump to 1.34.148 (diff)
downloadgentoo-a133cca44452ce79be6f7d19885eafb2b4d89542.tar.gz
gentoo-a133cca44452ce79be6f7d19885eafb2b4d89542.tar.bz2
gentoo-a133cca44452ce79be6f7d19885eafb2b4d89542.zip
app-admin/awscli: Bump to 1.33.30
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.33.30.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index dd87d7e9c242..bcc8fb20b16b 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.33.26.gh.tar.gz 2757281 BLAKE2B 04d88160203ff9cfc0c0f22dd9d57c70e
DIST aws-cli-1.33.27.gh.tar.gz 2758530 BLAKE2B c40db2483f0561078d1dc191e1d8c97bae0d0ab00f0ca11db796213567943f7dd816143340c6c9b9c28012d2881d860948138cc41b37555b7416a5289c7a5cd8 SHA512 3716ef6b5ab7db33496f31445d6ec404b89fc8a3fec564dd6644d43d4ea0db12aadcce545a481e955a166000386d8183e801780b6ac16e03bbea0f5ed9a495c5
DIST aws-cli-1.33.28.gh.tar.gz 2762159 BLAKE2B 6e4f7e0696532aa65ed1f22fac6c91e58b08507dda7ca5f6cb2a91e498006b8aa4a759056472bed376f7421aa6956a58bef55266124dc83e516441e883f87d37 SHA512 2a6921a139957d23cc2f186907f5cbccfc427beb870b9b9420e4578845e1c5931d71e32d0d0ea8badb0009d1540373197793e628d6146b7ebf7e637a0fdf5e8b
DIST aws-cli-1.33.29.gh.tar.gz 2762758 BLAKE2B 352c0b1d861c48df629f880db5b3ef5227128cb35671b0a276521540eeb6e43b627faacacb6e0dd9d35fa9ad8a074529cb7057316c3e05f9132fbf5025064402 SHA512 8594a0034937401337f5b4d05a7a567a8eff3ec6ba154962e8360946ac04e3666794e143a15ba55eba2910d4201dfce55474e6a7f982399c1fc364c0e99c1b92
+DIST aws-cli-1.33.30.gh.tar.gz 2764485 BLAKE2B 0fe483207532b180180e6a3dd81ec93ad6254fbea56ce22de67d0f9f49414db72b6ab1a434c77aac702db2a217e425e3cd4bf021dcc224d64f201c479376c326 SHA512 47b3e856cc93d0e70548a5eae53fc37dfa17982143e886480b1ab3569965d63c73db3b3c7f196c09402d8c368784c253a3f0c415e1a392b8462d8d79ac6a39ec
diff --git a/app-admin/awscli/awscli-1.33.30.ebuild b/app-admin/awscli/awscli-1.33.30.ebuild
new file mode 100644
index 000000000000..c212ce9cac21
--- /dev/null
+++ b/app-admin/awscli/awscli-1.33.30.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).(z+118), sigh
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(( $(ver_cut 3-) + 118 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}