summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-10 06:33:09 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-10 06:33:09 +0200
commitc004a1b580c4e2a81be5a035dd5f874694471658 (patch)
tree17dd77c1afa18fc01f25851ba564a1b48d998a12 /app-admin
parentdev-python/boto3: Bump to 1.34.158 (diff)
downloadgentoo-c004a1b580c4e2a81be5a035dd5f874694471658.tar.gz
gentoo-c004a1b580c4e2a81be5a035dd5f874694471658.tar.bz2
gentoo-c004a1b580c4e2a81be5a035dd5f874694471658.zip
app-admin/awscli: Bump to 1.33.40
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.33.40.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 4fd09e59a5d8..1cbc7f885d41 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST aws-cli-1.33.36.gh.tar.gz 2768813 BLAKE2B dbeaf0049d855da5b20c6ce24201dca43
DIST aws-cli-1.33.37.gh.tar.gz 2769229 BLAKE2B 39ef0d26e555f197cb4b4b588dc1fc9cad1562ba15926e349cae6e409bced94443403c6975ce08c69431accc45557e5659c6a23b686c7d046a7a338b4968a6a1 SHA512 d50150e04695ac651d27c7bdd23e79b5031f9e54fe2f00e6c1b78b5d2a22afac34a242e6473de52c813d85c219274fca472abb9dc70318c203a7638d2f869e42
DIST aws-cli-1.33.38.gh.tar.gz 2769355 BLAKE2B fd943a5d41a2426ad022156f48f972915d019e0e20ab9b64d498426402c0fa5d1ab45ffd1927fcc5a49d62266c3b02a81c3875f396e3fc919fcaae1e9b8d5f1e SHA512 27759a759eabe66d2b3058e1c8acb747debf34f5b737f5096937886771d754f3a926a7da82d4fc4e68cd118338a86945f6f4ecc3d23f297af32f12aa1a8f1323
DIST aws-cli-1.33.39.gh.tar.gz 2769718 BLAKE2B 5e391d01bce3beb424c4ae3456c782db8471aa6bc9f06d78b2855bfbf873dd41b5c7477a43bf80e7b996b5100c962024b5f5466b3772cbace319e6dbb01403c6 SHA512 00eb50f95d786abfa52591f3bc811854dfb769e0a1541d37c846a11553aba1ebe58f851d52d42720472abdab76e269e1b398595ca1bd5c11eb68912b3e8c7eb4
+DIST aws-cli-1.33.40.gh.tar.gz 2769444 BLAKE2B a26e26cb4694460e36fe2d9730092db33aff74e436642f3de5f94dc2fcbb594bb1ef2db425584359f50d0ae37be8be6034a0e722968a0ea4179e888b2f23be7c SHA512 d19d762a1ca0b02f3076d9241be19755f74c2b228cdb258f873d73dc91f25730b40e4a82bed3cb77e94b30ba34e1260629a3af6e7a7b7df108522d21103f34bb
diff --git a/app-admin/awscli/awscli-1.33.40.ebuild b/app-admin/awscli/awscli-1.33.40.ebuild
new file mode 100644
index 000000000000..c212ce9cac21
--- /dev/null
+++ b/app-admin/awscli/awscli-1.33.40.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).(z+118), sigh
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(( $(ver_cut 3-) + 118 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}