summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNRK <nrk@disroot.org>2024-06-09 11:23:18 +0000
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-11 08:29:51 +0300
commita999b2805f728b160f95414b3aa8c7dd4d9f8acf (patch)
tree77c18ec4674e56babdee6353649946dc673a34ad /app-arch/7zip
parentdev-lang/jwasm: fix makefile dependency order (diff)
downloadgentoo-a999b2805f728b160f95414b3aa8c7dd4d9f8acf.tar.gz
gentoo-a999b2805f728b160f95414b3aa8c7dd4d9f8acf.tar.bz2
gentoo-a999b2805f728b160f95414b3aa8c7dd4d9f8acf.zip
app-arch/7zip: fix makefile mkdir race
Closes: https://bugs.gentoo.org/933619 Signed-off-by: NRK <nrk@disroot.org> Closes: https://github.com/gentoo/gentoo/pull/37093 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-arch/7zip')
-rw-r--r--app-arch/7zip/7zip-23.01.ebuild1
-rw-r--r--app-arch/7zip/7zip-24.05.ebuild1
-rw-r--r--app-arch/7zip/7zip-24.06.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/app-arch/7zip/7zip-23.01.ebuild b/app-arch/7zip/7zip-23.01.ebuild
index 4393a0da0302..51c0b76b70b0 100644
--- a/app-arch/7zip/7zip-23.01.ebuild
+++ b/app-arch/7zip/7zip-23.01.ebuild
@@ -99,6 +99,7 @@ src_compile() {
args+=( MY_ASM=uasm )
fi
+ mkdir -p "${bdir}" || die # Bug: https://bugs.gentoo.org/933619
emake ${args[@]}
popd > /dev/null || die "Unable to switch directory"
}
diff --git a/app-arch/7zip/7zip-24.05.ebuild b/app-arch/7zip/7zip-24.05.ebuild
index 4393a0da0302..51c0b76b70b0 100644
--- a/app-arch/7zip/7zip-24.05.ebuild
+++ b/app-arch/7zip/7zip-24.05.ebuild
@@ -99,6 +99,7 @@ src_compile() {
args+=( MY_ASM=uasm )
fi
+ mkdir -p "${bdir}" || die # Bug: https://bugs.gentoo.org/933619
emake ${args[@]}
popd > /dev/null || die "Unable to switch directory"
}
diff --git a/app-arch/7zip/7zip-24.06.ebuild b/app-arch/7zip/7zip-24.06.ebuild
index 4c6458379962..a6bf83168b8c 100644
--- a/app-arch/7zip/7zip-24.06.ebuild
+++ b/app-arch/7zip/7zip-24.06.ebuild
@@ -99,6 +99,7 @@ src_compile() {
args+=( MY_ASM=uasm )
fi
+ mkdir -p "${bdir}" || die # Bug: https://bugs.gentoo.org/933619
emake ${args[@]}
popd > /dev/null || die "Unable to switch directory"
}