summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/arj/files/arj-3.10.22-darwin.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/arj/files/arj-3.10.22-darwin.patch')
-rw-r--r--app-arch/arj/files/arj-3.10.22-darwin.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-arch/arj/files/arj-3.10.22-darwin.patch b/app-arch/arj/files/arj-3.10.22-darwin.patch
new file mode 100644
index 000000000000..a09c30d3126d
--- /dev/null
+++ b/app-arch/arj/files/arj-3.10.22-darwin.patch
@@ -0,0 +1,41 @@
+--- arj-3.10.22/environ.c
++++ arj-3.10.22/environ.c
+@@ -58,7 +58,7 @@
+ #include <sys/ioctl.h>
+ #include <sys/statfs.h>
+ #include <sys/statvfs.h>
+- #elif defined(__FreeBSD__)||defined(__NetBSD__)
++ #elif defined(__FreeBSD__)||defined(__NetBSD__)||defined(__APPLE__)
+ #include <sys/param.h>
+ #include <sys/mount.h>
+ #elif defined(__QNXNTO__)
+--- arj-3.10.22/gnu/configure.in
++++ arj-3.10.22/gnu/configure.in
+@@ -62,6 +62,11 @@
+ DLL_FLAGS="-shared -export-dynamic"
+ LD_STRIP="gnu/stripgcc.lnk"
+ ;;
++*darwin*)
++ # not ELF
++ DLL_EXT=".dylib"
++ DLL_FLAGS=""
++ ;;
+ interix3*)
+ # not ELF
+ DLL_FLAGS="-shared"
+--- arj-3.10.22/arjcrypt.c
++++ arj-3.10.22/arjcrypt.c
+@@ -329,6 +329,13 @@
+ }
+ #endif
+
++#if defined(__APPLE__)
++int main()
++{
++ return(0);
++}
++#endif
++
+ /* External entry */
+
+ #if TARGET==DOS