summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-06-08 10:28:34 -0400
committerMike Gilbert <floppym@gentoo.org>2024-06-08 10:29:40 -0400
commit0f0d3e8440c2b40338be937facc3fdce956f1805 (patch)
tree721b2a9a727853be5b1d16e766cf1ec56ef82632 /app-arch
parentdev-ml/stdune: Stabilize 3.10.0 amd64, #933822 (diff)
downloadgentoo-0f0d3e8440c2b40338be937facc3fdce956f1805.tar.gz
gentoo-0f0d3e8440c2b40338be937facc3fdce956f1805.tar.bz2
gentoo-0f0d3e8440c2b40338be937facc3fdce956f1805.zip
app-arch/unar: update objc check
Drop pkg_pretend. Use positive USE flag checks. Closes: https://bugs.gentoo.org/933814 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unar/unar-1.10.8.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/app-arch/unar/unar-1.10.8.ebuild b/app-arch/unar/unar-1.10.8.ebuild
index 77668d74dd51..a2c9123da345 100644
--- a/app-arch/unar/unar-1.10.8.ebuild
+++ b/app-arch/unar/unar-1.10.8.ebuild
@@ -35,22 +35,18 @@ PATCHES=( "${FILESDIR}"/${P}-Wint-conversion.patch )
check_objc_toolchain() {
if tc-is-gcc; then
- has_version 'sys-devel/gcc[-objc]' &&
+ has_version 'sys-devel/gcc[objc]' ||
die "GCC requires sys-devel/gcc with USE=objc"
elif tc-is-clang; then
- has_version 'gnustep-base/gnustep-make[-libobjc2]' &&
+ has_version 'gnustep-base/gnustep-make[libobjc2]' ||
die "Clang requires gnustep-base/gnustep-make with USE=libobjc2"
else
die "${PN} can only be build using GCC or Clang"
fi
}
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && check_objc_toolchain
-}
-
pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && check_objc_toolchain
+ [[ ${MERGE_TYPE} == binary ]] || check_objc_toolchain
}
src_prepare() {