summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-06-16 09:33:43 +0200
committerFabian Groffen <grobian@gentoo.org>2024-06-16 09:33:43 +0200
commit8bfcabf96671e1d25c60c5b54f06078269a005b2 (patch)
treeee4a56170190bed3f1f27acdaf8fe93438fbb217 /app-arch
parentx11-libs/goocanvas: fix gcc-14 (diff)
downloadgentoo-8bfcabf96671e1d25c60c5b54f06078269a005b2.tar.gz
gentoo-8bfcabf96671e1d25c60c5b54f06078269a005b2.tar.bz2
gentoo-8bfcabf96671e1d25c60c5b54f06078269a005b2.zip
app-arch/zstd-1.5.6: unbreak build on non-ELF platforms
Basically unbreak the build on any platform where the linker/assembler doesn't grok the noexecstack arguments. Use test-flags-CCLD to invoke the linker/assembler after the compiler so the linker/assembler flags actually get tested, instead of just ignored by the compiler (which just passes them on). Bug: https://bugs.gentoo.org/903923 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/zstd/zstd-1.5.6.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-arch/zstd/zstd-1.5.6.ebuild b/app-arch/zstd/zstd-1.5.6.ebuild
index 8197ff6bba36..605eaa0f47f8 100644
--- a/app-arch/zstd/zstd-1.5.6.ebuild
+++ b/app-arch/zstd/zstd-1.5.6.ebuild
@@ -54,8 +54,8 @@ multilib_src_configure() {
# explicitly specified. See #903923
# The cmake build sets these, but the meson build doesn't, so set it manually.
# https://github.com/facebook/zstd/blob/979b047/build/cmake/CMakeModules/AddZstdCompilationFlags.cmake#L77-L82
- append-flags $(test-flags "-Wa,--noexecstack")
- append-ldflags $(test-flags "-Wl,-z,noexecstack")
+ append-flags $(test-flags-CCLD "-Wa,--noexecstack")
+ append-ldflags $(test-flags-CCLD "-Wl,-z,noexecstack")
local emesonargs=(
-Ddefault_library=$(multilib_native_usex static-libs both shared)