summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Miller <alex.miller@gmx.de>2024-04-16 13:56:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-06-02 10:00:41 +0300
commitdda8854fe9fdffee3e166d6548534f93980107e4 (patch)
treec51d753a07e3d3046bc36842b73c92a9356bdb48 /app-arch
parentnet-p2p/freenet: Add dep on dev-java/commons-io (diff)
downloadgentoo-dda8854fe9fdffee3e166d6548534f93980107e4.tar.gz
gentoo-dda8854fe9fdffee3e166d6548534f93980107e4.tar.bz2
gentoo-dda8854fe9fdffee3e166d6548534f93980107e4.zip
app-arch/torrentzip: drop 0.9-r1, 1.2-r1
Closes: https://bugs.gentoo.org/920358 Closes: https://github.com/gentoo/gentoo/pull/36279 Signed-off-by: Alexander Miller <alex.miller@gmx.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/torrentzip/Manifest2
-rw-r--r--app-arch/torrentzip/files/torrentzip-0.9-autoconf-quote.patch8
-rw-r--r--app-arch/torrentzip/files/torrentzip-1.2-checksum-detection.patch51
-rw-r--r--app-arch/torrentzip/torrentzip-0.9-r1.ebuild27
-rw-r--r--app-arch/torrentzip/torrentzip-1.2-r1.ebuild28
5 files changed, 0 insertions, 116 deletions
diff --git a/app-arch/torrentzip/Manifest b/app-arch/torrentzip/Manifest
index 08aa339c1310..387677f363eb 100644
--- a/app-arch/torrentzip/Manifest
+++ b/app-arch/torrentzip/Manifest
@@ -1,3 +1 @@
-DIST torrentzip-0.9.tar.gz 59007 BLAKE2B eb5d7d8d9026115367afd88ef0cf33d2eed600e6eaa773f039a713c76a48a39e12cb5a8ac6faf2937d3563c9270029543bdb6361d2f22a39e2341953872f589c SHA512 691cd25f501de3de16b5b15b2afadfc34b833c3e93208c2c3497674936580ad2c3532a02e02531b89974302eee7b36f7579a412718914b1b38044b78a39a4d4d
-DIST trrntzip-1.2.tar.gz 62707 BLAKE2B 289ddfe89b91c63b1a6902ea7a4055fa8e235e712d6ea911da2848cc8db15cbdf712967b9fcc1414513c1a18eef160108f5f7b03aefd8f8f18c4d04907a16c17 SHA512 90c853efde1d077c741206362bc14fe779627f1b20571246e99ed29980840e78c0377110431c59c35596a0d209e612f6fe77b385707eb4bdb1ea47bb797c9272
DIST trrntzip-1.3.tar.gz 67297 BLAKE2B c77fd134cfd3ab30f46b66f4b3dd36b899ee6267b17100b1ad15bdf5c6beddaea94fe22d23f1a81de85522768d76401f0192d0deac2ff75edc816510c8069e2c SHA512 c21ed6ac4dacd652e2a67b700741d70dd9da699259bd299ca177c741111f92e70eef0b3ad2ced54b5635780cab2b4c46b3f9c258dfa18bdde24e2718c38339be
diff --git a/app-arch/torrentzip/files/torrentzip-0.9-autoconf-quote.patch b/app-arch/torrentzip/files/torrentzip-0.9-autoconf-quote.patch
deleted file mode 100644
index f1f15ced173e..000000000000
--- a/app-arch/torrentzip/files/torrentzip-0.9-autoconf-quote.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -1,4 +1,4 @@
--AC_INIT([TorrentZip], [0.0], [StatMan, shindakun, Ultrasubmarine, r3nh03k <http://trrntzip.sf.net>], [trrntzip])
-+AC_INIT([TorrentZip], [0.9], [[StatMan, shindakun, Ultrasubmarine, r3nh03k <http://trrntzip.sf.net>]], [trrntzip])
-
- AM_INIT_AUTOMAKE
- AM_CONFIG_HEADER(config.h)
diff --git a/app-arch/torrentzip/files/torrentzip-1.2-checksum-detection.patch b/app-arch/torrentzip/files/torrentzip-1.2-checksum-detection.patch
deleted file mode 100644
index ac1ae14cbe03..000000000000
--- a/app-arch/torrentzip/files/torrentzip-1.2-checksum-detection.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 016915e16f32105590a6dc11a4adc988b2f8d9a9 Mon Sep 17 00:00:00 2001
-From: Alexander Miller <alex.miller@gmx.de>
-Date: Mon, 4 Mar 2024 19:26:21 +0100
-Subject: [PATCH] Fix broken detection of missing or wrong TORRENTZIPPED-...
- comment
-
-The commit listed below introduces a regression where in MigrateZip(),
-variable rc would be clobbered when its value is still needed. That
-completely breaks handling of zips that should be re-zipped because
-of missing or out of date TORRENTZIPPED-... comment.
-
-Rewrite the offending code such that it no longer touches the variable.
-
-Fixes: cf11c900079e ("Check for more errors while reading zip entries")
----
- src/trrntzip.c | 20 ++++++++++++--------
- 1 file changed, 12 insertions(+), 8 deletions(-)
-
-diff --git a/src/trrntzip.c b/src/trrntzip.c
-index e55d217..49f796e 100644
---- a/src/trrntzip.c
-+++ b/src/trrntzip.c
-@@ -379,16 +379,20 @@ int MigrateZip(const char *zip_path, const char *pDir, WORKSPACE *ws,
-
- CHECK_DYNAMIC_STRING_ARRAY(ws->FileNameArray, ws->iElements);
- // Get the filelist from the zip file in original order in ws->FileNameArray
-- rc = GetFileList(UnZipHandle, ws);
-- if (rc != TZ_OK) {
-+ switch (GetFileList(UnZipHandle, ws)) {
-+ case TZ_OK:
-+ break;
-+ case TZ_CRITICAL:
- logprint3(stderr, mig->fProcessLog, ErrorLog(ws),
-- rc == TZ_CRITICAL
-- ? "Error allocating memory!\n"
-- : "Could not list contents of \"%s\". File is corrupted or "
-- "contains entries with bad names.\n",
-- szZipFileName);
-+ "Error allocating memory!\n");
-+ unzClose(UnZipHandle);
-+ return TZ_CRITICAL;
-+ default:
-+ logprint3(stderr, mig->fProcessLog, ErrorLog(ws),
-+ "Could not list contents of \"%s\". File is corrupted or "
-+ "contains entries with bad names.\n", szZipFileName);
- unzClose(UnZipHandle);
-- return rc;
-+ return TZ_ERR;
- }
- CHECK_DYNAMIC_STRING_ARRAY(ws->FileNameArray, ws->iElements);
-
diff --git a/app-arch/torrentzip/torrentzip-0.9-r1.ebuild b/app-arch/torrentzip/torrentzip-0.9-r1.ebuild
deleted file mode 100644
index ad564eefcc4c..000000000000
--- a/app-arch/torrentzip/torrentzip-0.9-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="Create identical zip archives over multiple systems"
-HOMEPAGE="https://sourceforge.net/projects/trrntzip"
-SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="sys-libs/zlib"
-DEPEND="${RDEPEND}"
-
-DOCS=(README AUTHORS)
-
-PATCHES=("${FILESDIR}/${P}-autoconf-quote.patch")
-
-src_prepare() {
- default
- export CPPFLAGS+=" -DOF\\(args\\)=args"
- eautoreconf
-}
diff --git a/app-arch/torrentzip/torrentzip-1.2-r1.ebuild b/app-arch/torrentzip/torrentzip-1.2-r1.ebuild
deleted file mode 100644
index d526e0b88c10..000000000000
--- a/app-arch/torrentzip/torrentzip-1.2-r1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-MY_P="trrntzip-${PV}"
-DESCRIPTION="Create identical zip archives over multiple systems"
-HOMEPAGE="https://github.com/0-wiz-0/trrntzip"
-SRC_URI="https://github.com/0-wiz-0/trrntzip/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2+ ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- sys-libs/zlib:=
-"
-DEPEND="
- ${RDEPEND}
-"
-
-DOCS=(AUTHORS NEWS.md README.md)
-PATCHES=(
- "${FILESDIR}/${P}-checksum-detection.patch"
-)