summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 21:58:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 08:55:10 +0100
commit2d8b2bb2ee60846487964164b5fcda3ef4a49b09 (patch)
tree5d603c648117c25a6f8d53069b650bc324766400 /app-backup/backintime/backintime-9999.ebuild
parentx11-misc/kdocker: delete old (diff)
downloadgentoo-2d8b2bb2ee60846487964164b5fcda3ef4a49b09.tar.gz
gentoo-2d8b2bb2ee60846487964164b5fcda3ef4a49b09.tar.bz2
gentoo-2d8b2bb2ee60846487964164b5fcda3ef4a49b09.zip
app-backup/backintime: EAPI-7, xdg, fix QA, add missing PyQt5 RDEPENDs
Drop cd Drop LINGUAS hack Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-backup/backintime/backintime-9999.ebuild')
-rw-r--r--app-backup/backintime/backintime-9999.ebuild87
1 files changed, 36 insertions, 51 deletions
diff --git a/app-backup/backintime/backintime-9999.ebuild b/app-backup/backintime/backintime-9999.ebuild
index 91c3e3acf41b..fc293b01096b 100644
--- a/app-backup/backintime/backintime-9999.ebuild
+++ b/app-backup/backintime/backintime-9999.ebuild
@@ -1,87 +1,72 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_{6,7} )
-inherit python-single-r1 gnome2-utils git-r3
+inherit python-single-r1 git-r3 xdg
DESCRIPTION="Backup system inspired by TimeVault and FlyBack"
-HOMEPAGE="https://backintime.readthedocs.io/ https://github.com/bit-team/backintime/"
+HOMEPAGE="https://backintime.readthedocs.io/en/latest/ https://github.com/bit-team/backintime/"
EGIT_REPO_URI="https://github.com/bit-team/backintime/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="qt5"
+IUSE="examples qt5"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/keyring[${PYTHON_USEDEP}]
net-misc/openssh
- net-misc/rsync[xattr,acl]"
+ net-misc/rsync[xattr,acl]
+"
RDEPEND="${DEPEND}
- qt5? ( dev-python/PyQt5 )"
+ qt5? ( dev-python/PyQt5[gui,widgets] )
+"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_prepare() {
- #fix doc install location
- sed -e "s:/doc/${PN}-common:/doc/${PF}:g" \
- -i common/configure || die
- sed -e "s:/doc/${PN}-qt:/doc/${PF}:g" \
- -i qt/configure || die
- sed -e "/addInstallFile \"..\/VERSION/d" \
- -e "/addInstallFile \"..\/LICENSE/d" \
- -e "/addInstallFile \"..\/debian\/copyright/d" \
- -i {qt,common}/configure || die
-
- if [ -n ${LINGUAS+x} ] ; then
- cd common/po || die
- for po in *.po ; do
- if ! has ${po/.po} ${LINGUAS} ; then
- rm ${po} || die
- fi
- done
- fi
-
- default
-}
+PATCHES=( "${FILESDIR}/${PN}-1.2.1-no-compress-docs-examples.patch" )
src_configure() {
- cd "${S}"/common || die
- ./configure --python3 --no-fuse-group || die
+ pushd common > /dev/null || die
+ ./configure --python3 --no-fuse-group || die
+ popd > /dev/null || die
if use qt5 ; then
- cd "${S}"/qt || die
- ./configure --python3 || die
+ pushd qt > /dev/null || die
+ ./configure --python3 || die
+ popd > /dev/null || die
fi
}
src_compile() {
- cd "${S}"/common || die
- emake
- if use qt5 ; then
- cd "${S}"/qt || die
+ pushd common > /dev/null || die
emake
+ popd > /dev/null || die
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ emake
+ popd > /dev/null || die
fi
}
src_install() {
- cd "${S}"/common || die
- emake DESTDIR="${D}" install
- if use qt5 ; then
- cd "${S}"/qt || die
+ pushd common > /dev/null || die
emake DESTDIR="${D}" install
+ popd > /dev/null || die
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ emake DESTDIR="${D}" install
+ popd > /dev/null || die
fi
- python_optimize "${D}"
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
+ einstalldocs
+ if use examples ; then
+ docinto examples
+ dodoc common/{config-example-local,config-example-ssh}
+ fi
-pkg_postrm() {
- gnome2_icon_cache_update
+ python_optimize "${D}"
}