summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-07-29 15:07:04 +0100
committerMarek Szuba <marecki@gentoo.org>2023-07-29 15:49:30 +0100
commit0905dbbe9d5968a72f1dca75bdcc08bff0ba9eb2 (patch)
tree65d04829a1e58043880534dc5374d76d906af400 /app-backup
parentapp-admin/ansible-lint: add 6.17.2 (diff)
downloadgentoo-0905dbbe9d5968a72f1dca75bdcc08bff0ba9eb2.tar.gz
gentoo-0905dbbe9d5968a72f1dca75bdcc08bff0ba9eb2.tar.bz2
gentoo-0905dbbe9d5968a72f1dca75bdcc08bff0ba9eb2.zip
app-backup/borgmatic: add 1.8.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.8.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 45a80f0112e4..55e880788abf 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,3 +1,4 @@
DIST borgmatic-1.7.14.tar.gz 380875 BLAKE2B c30939392df03ce03feed4c5132ef99eaf9c676f51f7ad6b8bd536f45a7e76eff1871fc5bf0d7fd0025835b51325e961f538a661f2f6a78e0ce026550a9ecd84 SHA512 15f774b994d13ab224bcbcb0335145b5cf9a2fca04b098c15bf790c20fc5033073fe341a76d4e9dc8ad85e5fb898a0447c73fc5bc74d0ac9ec6900c333e6660b
DIST borgmatic-1.7.15.tar.gz 390819 BLAKE2B dc9086a0363afb8acbe943776cd6f388ba85a18e50554b5187c86e7054e7ff748ea878623d9b46c19564198faf5c566b137e54681812086115311970bc517455 SHA512 cf1f6da782a5ad547a76b9e4cb00cbd4ca4232cfb5dcd027c6fee9f1a3b97fda894f27c512007b449b8e11e939249060f63c3cdde29aee3aa86710200cf8d2db
DIST borgmatic-1.7.8.tar.gz 350233 BLAKE2B 3fcd392983f73ec5e97f0dc6b96e211d7f1e1d1a4ce95c635c675cf043e796925df53c30c1e4f8eb1a095d9ec5ff81e90edee5ff2576f4683053d3108004afd9 SHA512 bcc65fdb7ea1171fb61deda9b1f69a00596e1e10a99508d336977b694bd8f93d74837aad9211bf1065b785220aaf1460a3ea403bf23fa4873d1bf4c6b4016525
+DIST borgmatic-1.8.0.tar.gz 388945 BLAKE2B f765f135f4c4a99216928764ce769854d4364b20959ed547c07f3f9a88fa756765caf85fa4e726e7fd2bbfc704b509e860619383f53e731d9b44911ad930b65b SHA512 3b94095dcc0c8f199e59caafc0a3ec06780b7b87b532d4e7d666d2f84a8920d3671e47a0fd156ce67eae1e7914307c789a7bcf826fba46c0a7a34d333a14cde1
diff --git a/app-backup/borgmatic/borgmatic-1.8.0.ebuild b/app-backup/borgmatic/borgmatic-1.8.0.ebuild
new file mode 100644
index 000000000000..a4334bf572b4
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.8.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.13-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.7.14-systemd_service_bin_path.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " ${PN} config generate"
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.8.0; then
+ ewarn "Please be warned that ${PN}-1.8.0 has introduced several breaking changes."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://github.com/borgmatic-collective/borgmatic/releases/tag/1.8.0"
+ ewarn
+ break
+ fi
+ done
+ fi
+ elog
+ elog "Systemd users wishing to periodically run ${PN} can use the provided timer and service units."
+}