summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <rahil3108@gmail.com>2023-11-17 15:21:06 +0530
committerZac Medico <zmedico@gentoo.org>2023-11-28 22:16:32 -0800
commit0c50e695a8fd905fad1dfb26690403aa607114ba (patch)
tree4d1aebef10c43243aa2aa8198b989ae72a58ed8d /app-containers
parentdev-python/brotlicffi: Stabilize 1.1.0.0 x86, #915918 (diff)
downloadgentoo-0c50e695a8fd905fad1dfb26690403aa607114ba.tar.gz
gentoo-0c50e695a8fd905fad1dfb26690403aa607114ba.tar.bz2
gentoo-0c50e695a8fd905fad1dfb26690403aa607114ba.zip
app-containers/containers-common: add 0.57.0 and update live
1. Removing fix-warnings.patch as I don't see any warnings anymore 2. Add EPREFIX while installing 3. Misc Signed-off-by: Rahil Bhimjiani <rahil3108@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/containers-common/Manifest1
-rw-r--r--app-containers/containers-common/containers-common-0.57.0.ebuild68
-rw-r--r--app-containers/containers-common/containers-common-9999.ebuild12
3 files changed, 75 insertions, 6 deletions
diff --git a/app-containers/containers-common/Manifest b/app-containers/containers-common/Manifest
index 6c7325fe1c77..0ea2e1ba8627 100644
--- a/app-containers/containers-common/Manifest
+++ b/app-containers/containers-common/Manifest
@@ -1 +1,2 @@
DIST containers-common-0.56.0.tar.gz 12616120 BLAKE2B 6495ca7d0c9134bc8bd5f7b7541bb4f1160c74abb7a64bd4d2124104ea563f5381f0092da20ab45d81929a8632b1fcc1107ac05fdae011be446cff14ebf88c45 SHA512 4af720be95e6b5ca7d0664f99a389bf092b9f45d4e0602d9b49ef1d21b359d2307a94e0c88378fe0c751f5b40db54d7aab67eb497185a289cea9288cbfaa042c
+DIST containers-common-0.57.0.tar.gz 12700958 BLAKE2B 8432a7d839b94b59eabd75d4978a4d0c1340a64ed626db74e74a8318e08c61172bfba5e4f4c4b0dfffec302c5a310bb5be8fad3ab4d91a6d89ced373a0a6f297 SHA512 b993821040788085ff44e48023a64cea4e3e7e50731c359087bd287168e6849a543d930acbdaff2437fc7951acc46f7183f337dd977215eca814332e6869d1e3
diff --git a/app-containers/containers-common/containers-common-0.57.0.ebuild b/app-containers/containers-common/containers-common-0.57.0.ebuild
new file mode 100644
index 000000000000..f96e1c184a69
--- /dev/null
+++ b/app-containers/containers-common/containers-common-0.57.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Common config files and docs for Containers stack"
+HOMEPAGE="https://github.com/containers/common"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/common.git"
+else
+ SRC_URI="https://github.com/containers/common/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+RESTRICT="test"
+RDEPEND="
+ app-containers/containers-image
+ app-containers/containers-storage
+ app-containers/containers-shortnames
+ !<app-containers/podman-4.5.0-r1
+ net-firewall/nftables
+ net-firewall/iptables[nftables]
+ || ( app-containers/crun app-containers/runc )
+ || (
+ ( >=app-containers/netavark-1.6.0 >=app-containers/aardvark-dns-1.6.0 )
+ >=app-containers/cni-plugins-0.9.1
+ )
+"
+
+BDEPEND="
+ >=dev-go/go-md2man-2.0.2
+"
+
+src_prepare() {
+ default
+
+ [[ -f docs/Makefile && -f Makefile ]] || die
+ sed -i -e 's|/usr/local|/usr|g;' docs/Makefile Makefile || die
+
+ # add comments to mounts.conf
+ eapply "${FILESDIR}/examplify-mounts-conf.patch"
+}
+
+src_compile() {
+ emake docs
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ insinto /etc/containers
+ # https://github.com/containers/skopeo/raw/main/default-policy.json
+ doins pkg/config/containers.conf "${FILESDIR}/policy.json"
+
+ insinto /etc/containers/registries.d
+ # https://github.com/containers/skopeo/raw/main/default.yaml
+ doins "${FILESDIR}/default.yaml"
+
+ insinto /usr/share/containers
+ doins pkg/seccomp/seccomp.json pkg/subscriptions/mounts.conf
+
+ keepdir /etc/containers/certs.d /etc/containers/oci/hooks.d /etc/containers/systemd /var/lib/containers/sigstore
+}
diff --git a/app-containers/containers-common/containers-common-9999.ebuild b/app-containers/containers-common/containers-common-9999.ebuild
index 8963de7d6a47..f96e1c184a69 100644
--- a/app-containers/containers-common/containers-common-9999.ebuild
+++ b/app-containers/containers-common/containers-common-9999.ebuild
@@ -3,10 +3,10 @@
EAPI=8
-DESCRIPTION="Common config files and docs for Containers eco-system"
+DESCRIPTION="Common config files and docs for Containers stack"
HOMEPAGE="https://github.com/containers/common"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/containers/common.git"
else
@@ -39,10 +39,10 @@ BDEPEND="
src_prepare() {
default
- [[ -f docs/Makefile ]] || die
- sed -i -e 's|/usr/local|/usr|g;' docs/Makefile || die
+ [[ -f docs/Makefile && -f Makefile ]] || die
+ sed -i -e 's|/usr/local|/usr|g;' docs/Makefile Makefile || die
- eapply "${FILESDIR}/fix-warnings.patch"
+ # add comments to mounts.conf
eapply "${FILESDIR}/examplify-mounts-conf.patch"
}
@@ -51,7 +51,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install
+ emake DESTDIR="${ED}" install
insinto /etc/containers
# https://github.com/containers/skopeo/raw/main/default-policy.json