summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-11-04 00:10:24 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-11-04 01:19:32 +0100
commit4b6742313b2c4f09f4c38fb9b4a90df7602ee206 (patch)
treed2ce5d3a7c987102c351f02a3c4f1e58d3cc5022 /app-containers
parentsci-electronics/nvc: bump to 1.14.1 (diff)
downloadgentoo-4b6742313b2c4f09f4c38fb9b4a90df7602ee206.tar.gz
gentoo-4b6742313b2c4f09f4c38fb9b4a90df7602ee206.tar.bz2
gentoo-4b6742313b2c4f09f4c38fb9b4a90df7602ee206.zip
app-containers/devcontainer: bump to 0.72.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/devcontainer/Manifest1
-rw-r--r--app-containers/devcontainer/devcontainer-0.72.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-containers/devcontainer/Manifest b/app-containers/devcontainer/Manifest
index 156c3610e8f3..06fe47849875 100644
--- a/app-containers/devcontainer/Manifest
+++ b/app-containers/devcontainer/Manifest
@@ -1 +1,2 @@
DIST devcontainer-0.71.0.tgz 621743 BLAKE2B 6605d9c48d0041534f2982dd870b77e0453560be7652bbdac13a00e01fadbe0cd1c59048e70c7019bf2dab85ea9de2963bdcc03b7462e8c9a88cad8341ba7d0b SHA512 332d77983402672e3316c2285362d57679b7836a12bf1024a7e67580efdc601606dd851db5e2041a6e378a0abaed63c4a5d26a1372e32a420aa7823a7c907311
+DIST devcontainer-0.72.0.tgz 621831 BLAKE2B f762bfafab73dd03da65e5b0932cb5f067dc613c4e3889bc19b8be8da877a55f17577054617d7322478666b5fc25dc167ba84bd0efa9a1562eb27bdc6a893ce5 SHA512 bc3bf7dff2393cec35c0326670c6ce09359ddf14e4e1b6d5aee27d420af97a22d29753ac7ee7cde567de4d9aa02b51deaab36ab47ff13f208a0762d70cd22fdf
diff --git a/app-containers/devcontainer/devcontainer-0.72.0.ebuild b/app-containers/devcontainer/devcontainer-0.72.0.ebuild
new file mode 100644
index 000000000000..991cd956e37b
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.72.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}