summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-11-11 18:57:19 -0800
committerZac Medico <zmedico@gentoo.org>2024-11-11 18:59:25 -0800
commit6c1526c80474fea139d977702d47fd12095ef054 (patch)
treee6623e64012df6067767e66d241ae55f7b65789c /app-containers
parentapp-misc/mosquitto: Drop old versions (diff)
downloadgentoo-6c1526c80474fea139d977702d47fd12095ef054.tar.gz
gentoo-6c1526c80474fea139d977702d47fd12095ef054.tar.bz2
gentoo-6c1526c80474fea139d977702d47fd12095ef054.zip
app-containers/buildah: add 1.38.0
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/buildah/Manifest1
-rw-r--r--app-containers/buildah/buildah-1.38.0.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index cd9d367d2e1d..15b28e9ff037 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -4,3 +4,4 @@ DIST buildah-1.35.3.tar.gz 19372597 BLAKE2B 014bea80b3a8c4482bbe098a0c5293892cf9
DIST buildah-1.35.4.tar.gz 19370823 BLAKE2B 6dc8ad2a21c3ce41d4b8a2908d90bcbb32f5598c11fcde49a706334407370998731fedac7d8ee8e080a6a168c10b4a0404bf1120cab8b561e916a9df2bd2d115 SHA512 679f2328f675a39f9965128d51a6e8a3f82d64a6d3c3cdcb862cfcb7691eba272d869b6718147da1590aa573534081329ef05e879875024a11aa9ad52b2f292f
DIST buildah-1.36.0.tar.gz 19328201 BLAKE2B d3602b62a587d75904741b086bea6d789ac30fb6079b574214368552269e48310921340f42050c5c648173452fab7b478690fbfbd80bbebda4a5ec9a102aa4e6 SHA512 feb55b0dfb3cba4e9c6776b0f4730ebb4b9ea416f507e342f3b1cbf23b2bb79d96a58622faac7a980727e6739df7e0ceddf1a9d5ae483a3c7e781f7af75d115f
DIST buildah-1.37.5.tar.gz 19323742 BLAKE2B 1c03cc201f10f4d3645ecd3dac9ae97b3fe585b63ca8980e22e8b13d6dab05842c47e694b45c13875f03dadf0a656177445b0f3835a8a6faca63b288ff136013 SHA512 ee33d85ea3aa9ec423b4e48e19db69359e3fc480a61abd511fa473257aa326e9a9c4dafc985afb83f7caa9a7a5ba6a89b2a1c028fe6ef7bd4ef382ec8591331d
+DIST buildah-1.38.0.tar.gz 18547712 BLAKE2B a7c8df00ecc570d44173318adf68036389ce27bad5c10c7ba2bf7a728c29647186fcf0bfb9d0949e7947aff1e64cb2683b69ea0b4cb3d4181697813de8a5870f SHA512 c9f31693043e348c2bee6219f5a42738d93aa690a81f6bb283bd4d93ea6fe0cbde50754f7ee1a7e690853b7cfb934ce60e35ceb029180f41a95192773023c243
diff --git a/app-containers/buildah/buildah-1.38.0.ebuild b/app-containers/buildah/buildah-1.38.0.ebuild
new file mode 100644
index 000000000000..846ea4c76856
--- /dev/null
+++ b/app-containers/buildah/buildah-1.38.0.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module linux-info toolchain-funcs
+
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+
+# main pkg
+LICENSE="Apache-2.0"
+# deps
+LICENSE+=" BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+
+SLOT="0"
+IUSE="apparmor btrfs +seccomp systemd test"
+RESTRICT="test"
+DOCS=(
+ "CHANGELOG.md"
+ "troubleshooting.md"
+ "docs/tutorials"
+)
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/buildah.git"
+else
+ SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+RDEPEND="
+ systemd? ( sys-apps/systemd )
+ btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp:= )
+ apparmor? ( sys-libs/libapparmor:= )
+ >=app-containers/containers-common-0.58.0-r1
+ app-crypt/gpgme:=
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-apps/shadow:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-go/go-md2man"
+
+pkg_pretend() {
+ local CONFIG_CHECK=""
+ use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
+ check_extra_config
+
+ linux_config_exists || ewarn "Cannot determine configuration of your kernel."
+}
+
+src_prepare() {
+ default
+
+ # ensure all necessary files are there
+ local file
+ for file in docs/Makefile hack/libsubid_tag.sh hack/apparmor_tag.sh \
+ hack/systemd_tag.sh btrfs_installed_tag.sh btrfs_tag.sh; do
+ [[ -f "${file}" ]] || die
+ done
+
+ sed -i -e "s|/usr/local|/usr|g" Makefile docs/Makefile || die
+ echo -e '#!/usr/bin/env bash\necho libsubid' > hack/libsubid_tag.sh || die
+
+ cat <<-EOF > hack/apparmor_tag.sh || die
+ #!/usr/bin/env bash
+ $(usex apparmor 'echo apparmor' echo)
+ EOF
+
+ use seccomp || {
+ cat <<-'EOF' > "${T}/disable_seccomp.patch"
+ --- a/Makefile
+ +++ b/Makefile
+ @@ -5 +5 @@
+ -SECURITYTAGS ?= seccomp $(APPARMORTAG)
+ +SECURITYTAGS ?= $(APPARMORTAG)
+ EOF
+ eapply "${T}/disable_seccomp.patch" || die
+ }
+
+ cat <<-EOF > hack/systemd_tag.sh || die
+ #!/usr/bin/env bash
+ $(usex systemd 'echo systemd' echo)
+ EOF
+
+ echo -e "#!/usr/bin/env bash\n echo" > btrfs_installed_tag.sh || die
+ cat <<-EOF > btrfs_tag.sh || die
+ #!/usr/bin/env bash
+ $(usex btrfs echo 'echo exclude_graphdriver_btrfs btrfs_noversion')
+ EOF
+
+ use test || {
+ cat <<-'EOF' > "${T}/disable_tests.patch"
+ --- a/Makefile
+ +++ b/Makefile
+ @@ -56 +56 @@
+ -all: bin/buildah bin/imgtype bin/copy bin/inet bin/tutorial docs
+ +all: bin/buildah docs
+ @@ -122 +122 @@
+ -docs: install.tools ## build the docs on the host
+ +docs: ## build the docs on the host
+ EOF
+ eapply "${T}/disable_tests.patch" || die
+ }
+
+}
+
+src_compile() {
+ # For non-live versions, prevent git operations which causes sandbox violations
+ # https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
+ [[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT=""
+
+ tc-export AS LD STRIP
+ export GOMD2MAN="$(command -v go-md2man)"
+ export SELINUXOPT=
+ default
+}
+
+src_test() {
+ emake test-unit
+}
+
+src_install() {
+ emake DESTDIR="${ED}" SELINUXOPT= install install.completions
+ einstalldocs
+}