summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2025-01-18 14:31:45 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2025-01-18 14:42:17 +0200
commit97eed6311e225106ef7155b202b5bc4dd86bf54c (patch)
treeed678e3e70721a80840133d81e5cec03cf6163fd /app-containers
parentnet-irc/rbot: enable ruby33 (diff)
downloadgentoo-97eed6311e225106ef7155b202b5bc4dd86bf54c.tar.gz
gentoo-97eed6311e225106ef7155b202b5bc4dd86bf54c.tar.bz2
gentoo-97eed6311e225106ef7155b202b5bc4dd86bf54c.zip
app-containers/docker-registry: drop 2.8.1, EAPI=7--
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/docker-registry/Manifest1
-rw-r--r--app-containers/docker-registry/docker-registry-2.8.1.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/app-containers/docker-registry/Manifest b/app-containers/docker-registry/Manifest
index a5925694786d..4cef544bc6a9 100644
--- a/app-containers/docker-registry/Manifest
+++ b/app-containers/docker-registry/Manifest
@@ -1,2 +1 @@
-DIST docker-registry-2.8.1.tar.gz 2007611 BLAKE2B abf3e630652f195cf3ad4d07e6d9845000e79d340b0bb8046528bb62592df754c125fd38a92d1af27d068fcd51910f80f356d6a894cb1b97f28d7042af24b898 SHA512 b9c8525051458ff4bf4592ca3ddba83c4325e88c6812ddb28c1567e331c1571f112e3b646ca970f0fe420f3b1d61d00f7151450d7b9948a08733606255731266
DIST docker-registry-2.8.2.tar.gz 2008415 BLAKE2B 824325f835b2c7cc18f711204b4a92d21f661129ee2b446e3fc42f0e064b8dde43f119bff29216625cfb5e25aec152225680148ae3fc157886acb1e248b6d3b5 SHA512 c2270c14e09399b10fa474a93855e542b82a7746764ec581a218826581e30b76d4d31ae8f91957b8e48a7c14c054b84091c73679e40dbdff1a5bd0de8b18af83
diff --git a/app-containers/docker-registry/docker-registry-2.8.1.ebuild b/app-containers/docker-registry/docker-registry-2.8.1.ebuild
deleted file mode 100644
index 773fa15bb205..000000000000
--- a/app-containers/docker-registry/docker-registry-2.8.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit golang-vcs-snapshot systemd
-
-EGIT_COMMIT="b5ca020cfbe998e5af3457fda087444cf5116496"
-EGO_PN="github.com/docker/distribution"
-
-DESCRIPTION="Docker Registry 2.0"
-HOMEPAGE="https://github.com/docker/distribution"
-SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 MIT ZLIB"
-SLOT="0"
-KEYWORDS="amd64 ~arm64"
-
-DEPEND="
- acct-group/registry
- acct-user/registry
-"
-RDEPEND="${DEPEND}"
-
-SVCNAME="registry"
-
-src_prepare() {
- default
- pushd src/${EGO_PN} || die
- eapply "${FILESDIR}"/${PN}-2.7.0-notification-metrics.patch
- sed -e "s/git describe.*/echo ${PV})/" \
- -e "s/git rev-parse.*/echo ${EGIT_COMMIT})/" \
- -e "s/-s -w/-w/" \
- -i Makefile || die
- popd || die
-}
-
-src_compile() {
- export -n GOCACHE XDG_CACHE_HOME #681072
- GOPATH="${S}" GO_BUILD_FLAGS="-v" emake -C src/${EGO_PN} binaries
-}
-
-src_install() {
- exeinto /usr/libexec/${PN}
- doexe src/${EGO_PN}/bin/*
- insinto /etc/docker/registry
- newins src/${EGO_PN}/cmd/registry/config-example.yml config.yml.example
- newinitd "${FILESDIR}/${SVCNAME}.initd" "${SVCNAME}"
- newconfd "${FILESDIR}/${SVCNAME}.confd" "${SVCNAME}"
- systemd_dounit "${FILESDIR}/${SVCNAME}.service"
- keepdir /var/log/${SVCNAME}
- fowners ${SVCNAME}:${SVCNAME} /var/log/${SVCNAME}
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${SVCNAME}.logrotated" "${SVCNAME}"
-}