summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-14 15:47:04 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-14 16:08:11 +0200
commitb98a92b4a166d9a58e8d93c9cdf16d33c6def79c (patch)
tree175f286cb3b9e7b1cb6b389968ecde4811651a56 /app-containers
parentdev-python/mypy: Remove old (diff)
downloadgentoo-b98a92b4a166d9a58e8d93c9cdf16d33c6def79c.tar.gz
gentoo-b98a92b4a166d9a58e8d93c9cdf16d33c6def79c.tar.bz2
gentoo-b98a92b4a166d9a58e8d93c9cdf16d33c6def79c.zip
app-containers/docker-pushrm: new package; add 1.9.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/docker-pushrm/Manifest2
-rw-r--r--app-containers/docker-pushrm/docker-pushrm-1.9.0.ebuild36
-rw-r--r--app-containers/docker-pushrm/metadata.xml22
3 files changed, 60 insertions, 0 deletions
diff --git a/app-containers/docker-pushrm/Manifest b/app-containers/docker-pushrm/Manifest
new file mode 100644
index 000000000000..54f1fe3b74b9
--- /dev/null
+++ b/app-containers/docker-pushrm/Manifest
@@ -0,0 +1,2 @@
+DIST docker-pushrm-1.9.0-deps.tar.xz 121551972 BLAKE2B 2798ea5c23cfe300719ec99d1f76746dae379d9ea041e791f6b227c97678c2f0a017c3e4880a62cb6f40511c482997b1da4c4692c7ebad82435edbad30eaea2c SHA512 496f9d059951057f4a3f8d97ef7d50574e9634e29082dae471ce9f7139da40b730db744cbf420ae8da88592d62f4d52b1a24c30b877f1de639f7b5b52f2f6217
+DIST docker-pushrm-1.9.0.tar.gz 211628 BLAKE2B b8b470a97a0580596cfc90ce65ee289e32f49b2cb8a216138f534aac23c21f6007ef5b6d0bc2e9513a6800c7bda22e44ec0bb56ee3e7abe59961f4385928c98a SHA512 c9f3258b9d8660808a55f53ae30eca05d7725cb313a6c46018d7bbfd1feea28a2bfea2153700dfd43a7d4239683eb126f5daa2b29c88467d66620701b0244726
diff --git a/app-containers/docker-pushrm/docker-pushrm-1.9.0.ebuild b/app-containers/docker-pushrm/docker-pushrm-1.9.0.ebuild
new file mode 100644
index 000000000000..76bccc9ef6fc
--- /dev/null
+++ b/app-containers/docker-pushrm/docker-pushrm-1.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Docker CLI plugin to update container repository documentation"
+HOMEPAGE="https://github.com/docker/buildx"
+SRC_URI="
+ https://github.com/christian-korneck/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-containers/docker-cli
+"
+
+src_compile() {
+ local -a go_build_opts=(
+ -o ./bin/
+ )
+ ego build "${go_build_opts[@]}"
+}
+
+src_install() {
+ exeinto /usr/libexec/docker/cli-plugins
+ doexe "bin/${PN}"
+
+ einstalldocs
+}
diff --git a/app-containers/docker-pushrm/metadata.xml b/app-containers/docker-pushrm/metadata.xml
new file mode 100644
index 000000000000..2ee012065b84
--- /dev/null
+++ b/app-containers/docker-pushrm/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">christian-korneck/docker-pushrm</remote-id>
+ <bugs-to>https://github.com/christian-korneck/docker-pushrm/issues/</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ docker-pushrm is a Docker CLI plugin that adds a new docker pushrm
+ command to Docker. It pushes the README file from the current working
+ directory to a container registry server where it appears as repo
+ description in the web interface. It currently supports Docker Hub, Red
+ Hat Quay and Harbor v2. For most registry types docker-pushrm uses
+ authentication info from the Docker credentials store - so it "just
+ works" for registry servers that you're already logged into with Docker.
+ </longdescription>
+</pkgmetadata>