summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-30 04:44:04 +0100
committerSam James <sam@gentoo.org>2023-05-30 04:44:12 +0100
commitfef574684297c8e156a932ad9c83eb20c8efe62d (patch)
tree814b5ccd07cd02b79bbbc58cf9a4785ceb6b636f /app-doc/eclass-manpages/eclass-manpages-20230530.ebuild
parentnet-p2p/freenet: drop versions (diff)
downloadgentoo-fef574684297c8e156a932ad9c83eb20c8efe62d.tar.gz
gentoo-fef574684297c8e156a932ad9c83eb20c8efe62d.tar.bz2
gentoo-fef574684297c8e156a932ad9c83eb20c8efe62d.zip
app-doc/eclass-manpages: add 20230530
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-doc/eclass-manpages/eclass-manpages-20230530.ebuild')
-rw-r--r--app-doc/eclass-manpages/eclass-manpages-20230530.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-doc/eclass-manpages/eclass-manpages-20230530.ebuild b/app-doc/eclass-manpages/eclass-manpages-20230530.ebuild
new file mode 100644
index 000000000000..a48746c8b4c9
--- /dev/null
+++ b/app-doc/eclass-manpages/eclass-manpages-20230530.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Instructions to make a dist tarball:
+# git clone https://github.com/projg2/eclass-to-manpage.git
+# cd eclass-to-manpage
+# make dist ECLASSDIR=~/g/eclass/
+
+DESCRIPTION="Collection of Gentoo eclass manpages"
+HOMEPAGE="https://github.com/projg2/eclass-to-manpage"
+SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Keep the keywords stable. No need to change to ~arch.
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="sys-apps/gawk"
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+}