summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-11-12 19:55:02 +0100
committerUlrich Müller <ulm@gentoo.org>2024-11-12 19:56:02 +0100
commit8e48ae399125ca5c3328399bcd1b55d8725426f2 (patch)
tree1c9346b7f68f2699813920987ec954ba86a3b282 /app-doc
parentmail-mta/msmtp: Stabilize 1.8.27 ppc, #943317 (diff)
downloadgentoo-8e48ae399125ca5c3328399bcd1b55d8725426f2.tar.gz
gentoo-8e48ae399125ca5c3328399bcd1b55d8725426f2.tar.bz2
gentoo-8e48ae399125ca5c3328399bcd1b55d8725426f2.zip
app-doc/devmanual: add 0_pre20241109
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/devmanual/Manifest1
-rw-r--r--app-doc/devmanual/devmanual-0_pre20241109.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-doc/devmanual/Manifest b/app-doc/devmanual/Manifest
index 7f91da457ed7..2a45283f4ab1 100644
--- a/app-doc/devmanual/Manifest
+++ b/app-doc/devmanual/Manifest
@@ -1,2 +1,3 @@
DIST devmanual-0_pre20231106.tar.xz 187040 BLAKE2B 20992be79db2b581234a813740bd59c697af624d6edc86e29375078b63cdc13bed3eae116e21d2b82d568703983860cae7be00649f24eb90f2a6f6b7837525d7 SHA512 0434e0155876dff01105ac014528d8abaa19631c5b260d2c8c995c417053403ae652d4e082d0a08549994e3238024ed2592b145c6b0435ed84f87397fb7aeacc
DIST devmanual-0_pre20241031.tar.xz 187940 BLAKE2B 48ee136dcad8cf2766ea00cd8440b30e8e5a0460480f242417935c4b43bc46df0b36166d6a65a11a875d0ab4399dd8825cd75be3f1d32905d1243ecef6f51717 SHA512 0a9ac7978f0415f5c7cf6cb9faeecb42d91939b69522b2693122da714c9917186d5eff0eb44af14ecf433c525288a0863fdacdfa4b2baa486a600c97987660d0
+DIST devmanual-0_pre20241109.tar.xz 187844 BLAKE2B 91e6d470e6a599d3437646ae884bf85a66482ca630ec2cf4f181ae2e9b785af57826dc4390b0c69525f23a68a664c8ea2d97ac3b74404b268d1fa1521ec12d81 SHA512 537a1a196efb3136c28bf8ff4edd48608bfb1ef01f92e5c8e0af7bb8f81fe58dcc2f971be22233b0d96a7a1906f1a9739f5583ccdd80e0fccbe58a21cc77e59d
diff --git a/app-doc/devmanual/devmanual-0_pre20241109.ebuild b/app-doc/devmanual/devmanual-0_pre20241109.ebuild
new file mode 100644
index 000000000000..eb6eb3a9d985
--- /dev/null
+++ b/app-doc/devmanual/devmanual-0_pre20241109.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="xml(+)"
+inherit python-any-r1 readme.gentoo-r1
+
+DESCRIPTION="The Gentoo Development Guide"
+HOMEPAGE="https://devmanual.gentoo.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/devmanual.git"
+else
+ # "make dist" in devmanual repo
+ SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+ S="${WORKDIR}/${PN}"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+IUSE="+offline test"
+RESTRICT="!test? ( test )"
+
+BDEPEND=">=dev-libs/libxml2-2.9.12
+ dev-libs/libxslt
+ gnome-base/librsvg
+ media-fonts/open-sans
+ ${PYTHON_DEPS}
+ test? ( >=app-text/htmltidy-5.8.0 )"
+
+src_compile() {
+ emake OFFLINE=$(usex offline 1 0)
+}
+
+src_install() {
+ emake OFFLINE=$(usex offline 1 0) \
+ DESTDIR="${D}" \
+ htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
+
+ local DOC_CONTENTS="In order to browse the Gentoo Development Guide in
+ offline mode, point your browser to the following url:
+ file://${EPREFIX}/usr/share/doc/${PF}/html/index.html"
+ if ! has_version app-doc/eclass-manpages; then
+ DOC_CONTENTS+="\\n\\nThe offline version of the devmanual does not
+ include the documentation for the eclasses. If you need it,
+ then emerge app-doc/eclass-manpages."
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}