summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2022-05-19 08:58:39 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2022-05-19 09:01:42 +0200
commit770a0460a98e9245802321714ee2350fd230497d (patch)
tree6469392da0ef306887f05d347970e4da1ff2b927 /app-editors/hexedit
parentapp-text/bibletime: add 3.0.3 (diff)
downloadgentoo-770a0460a98e9245802321714ee2350fd230497d.tar.gz
gentoo-770a0460a98e9245802321714ee2350fd230497d.tar.bz2
gentoo-770a0460a98e9245802321714ee2350fd230497d.zip
app-editors/hexedit: add 1.6
Closes: https://bugs.gentoo.org/842711 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'app-editors/hexedit')
-rw-r--r--app-editors/hexedit/Manifest1
-rw-r--r--app-editors/hexedit/hexedit-1.6.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-editors/hexedit/Manifest b/app-editors/hexedit/Manifest
index aea3d3f41c94..3940f34afbef 100644
--- a/app-editors/hexedit/Manifest
+++ b/app-editors/hexedit/Manifest
@@ -1 +1,2 @@
DIST hexedit-1.5.tar.gz 30544 BLAKE2B d7292a70819826fddd63f99ee9d05073b8a59f51477390af91151146ee1f5a75333560829f0351fa9e158ef932c07a3582a3e822f42e645917a7fa321055d14e SHA512 9d8e5c8c0cda0af17ffeaf528e3dacd7fc2878dfc0755cb055dae5c56f05c961353c1d1723b05897314b49a44a6eb96de5d3a599c6b29967425507eea7cc7ca5
+DIST hexedit-1.6.tar.gz 31085 BLAKE2B e576de6aaed35449adbc430c95e8ba3a8ccfba587ef5c4d347d95b84c9764cb644323af23d46ff16429b93e0348c8d310afbad482219aa1b2c1b582332bd06fe SHA512 9783406f253a67fe048ec12306df1a601b7ba92cd7a0399ad2f103aed5a3164cd21ad7c1d547a4c55192cfb7da2b2517152015a4c3db402a9217548b435f602d
diff --git a/app-editors/hexedit/hexedit-1.6.ebuild b/app-editors/hexedit/hexedit-1.6.ebuild
new file mode 100644
index 000000000000..7da44e6f5b51
--- /dev/null
+++ b/app-editors/hexedit/hexedit-1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="View and edit files in hex or ASCII"
+HOMEPAGE="http://rigaux.org/hexedit.html"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+EGIT_REPO_URI="https://github.com/pixel/hexedit.git"
+else
+SRC_URI="https://github.com/pixel/hexedit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin hexedit
+ doman hexedit.1
+ dodoc Changes
+}