summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2021-09-20 18:42:41 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-10-31 10:21:21 +0200
commit32c96d50122cd4de336dc5a00816965cede95748 (patch)
tree62961c66b56cbb430bab7b0399e7f0dba83159c0 /app-editors/remarkable
parentdev-ruby/iobuffer: cleanup (diff)
downloadgentoo-32c96d50122cd4de336dc5a00816965cede95748.tar.gz
gentoo-32c96d50122cd4de336dc5a00816965cede95748.tar.bz2
gentoo-32c96d50122cd4de336dc5a00816965cede95748.zip
app-editors/remarkable: new package
remarkable is a full featured markdown editor, supporting the github markdown dialect Closes: https://bugs.gentoo.org/616208 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/22341 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/remarkable')
-rw-r--r--app-editors/remarkable/Manifest1
-rw-r--r--app-editors/remarkable/files/README.gentoo10
-rw-r--r--app-editors/remarkable/files/remarkable-1.9.0_pre20210320-disable-spellcheck.patch23
-rw-r--r--app-editors/remarkable/metadata.xml12
-rw-r--r--app-editors/remarkable/remarkable-1.9.0_pre20210320.ebuild66
5 files changed, 112 insertions, 0 deletions
diff --git a/app-editors/remarkable/Manifest b/app-editors/remarkable/Manifest
new file mode 100644
index 000000000000..9a5732e15b1a
--- /dev/null
+++ b/app-editors/remarkable/Manifest
@@ -0,0 +1 @@
+DIST remarkable-1.9.0_pre20210320.tar.gz 132617 BLAKE2B e3146ad354ebbe7972556d5952a576a1e242bd2aefca91948d75ae6c571fe3e1956e40184db4c5ca6a47f01130a7745101fe556c49854058b9fd110cb74783ae SHA512 0cfe1a01a198396dbc6f30d9e4ca4fa2de6624f29557d60053a7e446a0a3da3a577b32b25ba6eb93300316ede6afad4140ff75bd3e411e15cb1e5221d2b095d9
diff --git a/app-editors/remarkable/files/README.gentoo b/app-editors/remarkable/files/README.gentoo
new file mode 100644
index 000000000000..9533e5f0de44
--- /dev/null
+++ b/app-editors/remarkable/files/README.gentoo
@@ -0,0 +1,10 @@
+
+Known Gentoo-related issues:
+============================
+
+- export to HTML/PDF does not work (this feature would need the python module
+ "wkhtmltopdf" which is not packaged for gentoo and most probably will
+ never be - it depends on deprecated Qt WebKit)
+- spellchecking is disabled (would need python module pygtkspellcheck which)
+ is also not packaged for gentoo yet)
+
diff --git a/app-editors/remarkable/files/remarkable-1.9.0_pre20210320-disable-spellcheck.patch b/app-editors/remarkable/files/remarkable-1.9.0_pre20210320-disable-spellcheck.patch
new file mode 100644
index 000000000000..6dbd4cf48a8d
--- /dev/null
+++ b/app-editors/remarkable/files/remarkable-1.9.0_pre20210320-disable-spellcheck.patch
@@ -0,0 +1,23 @@
+Remove the spellcheck option permanently unless someone is packaging
+pygtkspellcheck for Gentoo
+
+Signed-off-by: Martin Dummer <martin.dummer@gmx.net>
+
+--- a/remarkable/RemarkableWindow.py
++++ b/remarkable/RemarkableWindow.py
+@@ -41,13 +41,8 @@
+ import warnings
+ from findBar import FindBar
+
+-# Check if gtkspellcheck is installed
+-try:
+- from gtkspellcheck import SpellChecker
+- spellcheck_enabled = True
+-except:
+- print("*Spellchecking not enabled.\n*To enable spellchecking install pygtkspellcheck\n*https://pypi.python.org/pypi/pygtkspellcheck/")
+- spellcheck_enabled = False
++# spellcheck permanently disabled
++spellcheck_enabled = False
+
+ import logging
+ logger = logging.getLogger('remarkable')
diff --git a/app-editors/remarkable/metadata.xml b/app-editors/remarkable/metadata.xml
new file mode 100644
index 000000000000..807eeb2b38c2
--- /dev/null
+++ b/app-editors/remarkable/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>martin.dummer@gmx.net</email>
+ <name>Martin Dummer</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-editors/remarkable/remarkable-1.9.0_pre20210320.ebuild b/app-editors/remarkable/remarkable-1.9.0_pre20210320.ebuild
new file mode 100644
index 000000000000..876a5a238409
--- /dev/null
+++ b/app-editors/remarkable/remarkable-1.9.0_pre20210320.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit desktop gnome2-utils python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="Fully featured markdown editor, supports github markdown dialect"
+HOMEPAGE="https://remarkableapp.github.io/ https://github.com/jamiemcg/remarkable"
+GIT_COMMIT="7b0b3dacef270a00c28e8852a88d74f72a3544d7"
+SRC_URI="https://github.com/jamiemcg/remarkable/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/Remarkable-${GIT_COMMIT}"
+
+LICENSE="BSD-2 GPL-2+ LGPL-2.1+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ net-libs/webkit-gtk[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-disable-spellcheck.patch )
+
+src_prepare() {
+ default
+ sed -i -e "s|import styles|from remarkable import styles|" \
+ -e "s|from findBar|from remarkable.findBar|" \
+ remarkable/RemarkableWindow.py || die
+}
+
+src_install() {
+ default
+
+ python_domodule markdown pdfkit remarkable remarkable_lib
+ python_doscript bin/remarkable
+ doicon data/ui/remarkable.png
+ domenu ${PN}.desktop
+
+ insinto /usr/share/${PN}
+ doins -r data/ui
+ doins -r data/media
+
+ insinto /usr/share/glib-2.0/schemas
+ doins data/glib-2.0/schemas/*
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}