summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-24 14:53:24 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-25 18:18:20 +0100
commit995a15c12a01a2864be60fba68bc2bbc203f19fd (patch)
treeebe0a824e0ff37ad946a78953a892d0e5c2d5765 /app-editors/retext
parentapp-admin/ansible-molecule: Use pypi.eclass (diff)
downloadgentoo-995a15c12a01a2864be60fba68bc2bbc203f19fd.tar.gz
gentoo-995a15c12a01a2864be60fba68bc2bbc203f19fd.tar.bz2
gentoo-995a15c12a01a2864be60fba68bc2bbc203f19fd.zip
app-editors/retext: Use pypi.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-editors/retext')
-rw-r--r--app-editors/retext/retext-8.0.0.ebuild9
-rw-r--r--app-editors/retext/retext-9999.ebuild9
2 files changed, 6 insertions, 12 deletions
diff --git a/app-editors/retext/retext-8.0.0.ebuild b/app-editors/retext/retext-8.0.0.ebuild
index 1ee7fbd39b8a..7f375768199a 100644
--- a/app-editors/retext/retext-8.0.0.ebuild
+++ b/app-editors/retext/retext-8.0.0.ebuild
@@ -7,12 +7,11 @@ EAPI=8
# old compat matrix is no longer accessible as of 2021-02-13 but stated back
# in 2020-07-05 that PyQt5 was explicitly not supported.
PYTHON_COMPAT=( python3_{9..11} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="ReText"
inherit distutils-r1 optfeature qmake-utils virtualx xdg
-MY_PN="ReText"
-MY_P="${MY_PN}-${PV/_/~}"
-
DESCRIPTION="Simple editor for Markdown and reStructuredText"
HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
@@ -20,9 +19,7 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/retext-project/retext.git"
else
- SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_P}"
-
+ inherit pypi
KEYWORDS="~amd64"
fi
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index 1ee7fbd39b8a..7f375768199a 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -7,12 +7,11 @@ EAPI=8
# old compat matrix is no longer accessible as of 2021-02-13 but stated back
# in 2020-07-05 that PyQt5 was explicitly not supported.
PYTHON_COMPAT=( python3_{9..11} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="ReText"
inherit distutils-r1 optfeature qmake-utils virtualx xdg
-MY_PN="ReText"
-MY_P="${MY_PN}-${PV/_/~}"
-
DESCRIPTION="Simple editor for Markdown and reStructuredText"
HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
@@ -20,9 +19,7 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/retext-project/retext.git"
else
- SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_P}"
-
+ inherit pypi
KEYWORDS="~amd64"
fi