summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-27 11:39:39 +0000
committerSam James <sam@gentoo.org>2022-12-27 11:39:39 +0000
commit367129e7ef4636b0599b12c0cf29977cdb46a2e1 (patch)
tree819fc2ca2718c40875a3af0143b7b43253d6eedc /app-editors/xvile
parentapp-editors/vile: add 9.8x (diff)
downloadgentoo-367129e7ef4636b0599b12c0cf29977cdb46a2e1.tar.gz
gentoo-367129e7ef4636b0599b12c0cf29977cdb46a2e1.tar.bz2
gentoo-367129e7ef4636b0599b12c0cf29977cdb46a2e1.zip
app-editors/xvile: add 9.8x
Bug: https://bugs.gentoo.org/880941 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/xvile')
-rw-r--r--app-editors/xvile/Manifest2
-rw-r--r--app-editors/xvile/xvile-9.8x.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/app-editors/xvile/Manifest b/app-editors/xvile/Manifest
index bcc2d7132cd3..ddc6f2346725 100644
--- a/app-editors/xvile/Manifest
+++ b/app-editors/xvile/Manifest
@@ -1,2 +1,4 @@
DIST vile-9.8w.tgz 2407322 BLAKE2B 824142c2d081db7c74ab4ce36db63e2d26e82954b32d274477f920b3519c75a249745365f7fb4f117f613c04fddd468394b4636d5f84d9f024eee3cb9c8332ba SHA512 54a96b400f479c633b917691fdab5ec5098ff1d6a6f5390c085635b4449ee7f02988e52c6b442918917455d02d5d74781ed57e4f944422576cf6532caaa446af
DIST vile-9.8w.tgz.asc 729 BLAKE2B 24ee3733957239b808566cf1c46cd45089ab0e9cd980fc477190beca79a85e6d31925c8eb02138442e4776b7ee678aec9d522d4bb3a8d72670e0720ab9369a5c SHA512 143eaa6ea64cf1d8dc078aba197544a036858f91a15f2f8c4254095f7cdc725b1720cf600afcd3ba67cf0c0414cefb0a058a5730d1a70906fe3591ddc46fb916
+DIST vile-9.8x.tgz 2476108 BLAKE2B a788f3a0544d2044e41aadd1d875ef62bd40179aa2090361a044862f0e7c801fdc8b0e3e71ae46c2406979babe499d5ed96fbf5f0ed87c2da1dbb0a3961f4f3b SHA512 099f38ffd58fb501b18a98b6be031cb51dc3c67f4d7f2e1b43763d4066d5b1f4e46d16e1d0302e437db6b4a27805c5696341e5a3da543adbde60211338732016
+DIST vile-9.8x.tgz.asc 729 BLAKE2B 30d033ac048b88c74f6115eeb2c09984a438e60cc4ad291532bdd0789408b9a4c0734d0322588741da2d66562258a8cb7ba557f5c7e212a4219bc6b2719d1407 SHA512 2138a256e00e2d68e747c09579ed4c4d946f6337cc3b2b8763a775871afd9acb96f1562746347632dd021b0528f0e2143e1bcba3b1e583c685f58e9f19af543a
diff --git a/app-editors/xvile/xvile-9.8x.ebuild b/app-editors/xvile/xvile-9.8x.ebuild
new file mode 100644
index 000000000000..f144b9e573aa
--- /dev/null
+++ b/app-editors/xvile/xvile-9.8x.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Bump with app-editors/vile
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+MY_P="${PN/x/}-${PV}"
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="https://invisible-island.net/vile/"
+SRC_URI="https://invisible-island.net/archives/vile/current/${MY_P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/vile/current/${MY_P}.tgz.asc )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~riscv ~sparc ~x86"
+IUSE="perl"
+
+RDEPEND="
+ ~app-editors/vile-${PV}
+ virtual/libcrypt:=
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libICE-1.0.0
+ >=x11-libs/libSM-1.0.0
+ >=x11-libs/libXaw-1.0.1
+ >=x11-libs/libXpm-3.5.4.2
+ perl? ( dev-lang/perl:= )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ app-alternatives/lex
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
+"
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ econf \
+ --disable-stripping \
+ --with-ncurses \
+ --with-pkg-config \
+ --with-x \
+ $(use_with perl)
+}
+
+src_install() {
+ dobin xvile
+ dodoc CHANGES* README doc/*.doc
+ docinto html
+ dodoc doc/*.html
+}