summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /app-editors
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/hexcurse/hexcurse-1.55.ebuild2
-rw-r--r--app-editors/ted/ted-2.23.ebuild2
-rw-r--r--app-editors/xemacs/xemacs-21.5.34-r4.ebuild5
3 files changed, 4 insertions, 5 deletions
diff --git a/app-editors/hexcurse/hexcurse-1.55.ebuild b/app-editors/hexcurse/hexcurse-1.55.ebuild
index d1d3c8134882..c0d5399a72b6 100644
--- a/app-editors/hexcurse/hexcurse-1.55.ebuild
+++ b/app-editors/hexcurse/hexcurse-1.55.ebuild
@@ -26,6 +26,6 @@ src_prepare() {
}
src_install() {
- emake install DESTDIR="${D}" || die "Install failed"
+ emake install DESTDIR="${D}"
dodoc AUTHORS ChangeLog NEWS README
}
diff --git a/app-editors/ted/ted-2.23.ebuild b/app-editors/ted/ted-2.23.ebuild
index 9d89f2ecb765..41d6280abf91 100644
--- a/app-editors/ted/ted-2.23.ebuild
+++ b/app-editors/ted/ted-2.23.ebuild
@@ -52,7 +52,7 @@ src_configure() {
local dir
for dir in appFrame appUtil bitmap docBuf ind Ted tedPackage; do
cd "${S}"/${dir}
- econf --cache-file=../config.cache || die "configure in ${dir} failed"
+ econf --cache-file=../config.cache
done
}
diff --git a/app-editors/xemacs/xemacs-21.5.34-r4.ebuild b/app-editors/xemacs/xemacs-21.5.34-r4.ebuild
index 487f5b97af04..8cf979775cf2 100644
--- a/app-editors/xemacs/xemacs-21.5.34-r4.ebuild
+++ b/app-editors/xemacs/xemacs-21.5.34-r4.ebuild
@@ -180,8 +180,7 @@ src_configure() {
--with-newgc \
--with-system-malloc \
--enable-option-checking=no \
- --with-last-packages=/usr/lib/xemacs \
- || die "configuration failed"
+ --with-last-packages=/usr/lib/xemacs
}
src_compile() {
@@ -194,7 +193,7 @@ src_install() {
infodir="${D}"/usr/share/info \
libdir="${D}"/usr/$(get_libdir) \
datadir="${D}"/usr/share \
- install || die
+ install
# Rename some applications installed in bin so that it is clear
# which application installed them and so that conflicting