summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-06-15 14:19:54 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-06-16 09:05:21 +0300
commit51cb39c87c9051e8a84bffe01b1b0698829109e4 (patch)
treecbe4a4d8541c3c0ea01cf2ac621ba4ceb9e0c68c /app-editors
parentapp-editors/pluma: adjust dependency for 1.28 (diff)
downloadgentoo-51cb39c87c9051e8a84bffe01b1b0698829109e4.tar.gz
gentoo-51cb39c87c9051e8a84bffe01b1b0698829109e4.tar.bz2
gentoo-51cb39c87c9051e8a84bffe01b1b0698829109e4.zip
app-editors/pluma-plugins: add 1.28.0
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/pluma-plugins/Manifest1
-rw-r--r--app-editors/pluma-plugins/pluma-plugins-1.28.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-editors/pluma-plugins/Manifest b/app-editors/pluma-plugins/Manifest
index 9eeb0b88a346..30437f2c59cd 100644
--- a/app-editors/pluma-plugins/Manifest
+++ b/app-editors/pluma-plugins/Manifest
@@ -1 +1,2 @@
DIST pluma-plugins-1.26.0.tar.xz 505652 BLAKE2B 09d34a3205796aab0b94b6e4d1c44b9902091b46511735b74a9cc1d1bee8a28352bf673ea7788eb4522e1dd0614a0399471aa8a076fd50f70bf1cf66e80326ad SHA512 ee59d52e0f879a5adf745c4be4a274f5c5b5403d7a9485236879e6e6db1c8f743de74be379fe84d2da73efe3eeb63bfa089a28f73762a6f0ceee0dbbbc464fa4
+DIST pluma-plugins-1.28.0.tar.xz 520696 BLAKE2B ebc5019e13993b51af1abc323b4a7d6dba32ba33cb7dc86286b10f8678d36e52db6d778482a2c0293f678e6158eef1b33878de0b27c83b22248e7df5ab801eb6 SHA512 63fc17649a967f15751541a1292e6dc9c318f2e66f30df3a477ee7b3dc6a2f3560512ed89a775b8e14fbc5942e06ed46099f0aa2ed24f7b4991146ad2ed55228
diff --git a/app-editors/pluma-plugins/pluma-plugins-1.28.0.ebuild b/app-editors/pluma-plugins/pluma-plugins-1.28.0.ebuild
new file mode 100644
index 000000000000..dc949ef42832
--- /dev/null
+++ b/app-editors/pluma-plugins/pluma-plugins-1.28.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A set of plugins for Pluma, the MATE text editor."
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="+python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=dev-libs/libpeas-1.14.1:0[gtk]
+ >=app-editors/pluma-1.28.0
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-4.0.2:4
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/pluma[${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libpeas:0[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ >=x11-libs/vte-0.52:2.91[introspection]
+ ')
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+
+ )"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable python)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ mate_src_install
+ use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+}