summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-29 23:43:57 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-29 23:48:38 +0100
commitf47bbcf675b0977c877caa9aa19e5484523041d9 (patch)
tree4909b594985e61d0b3fc6d7b9ae2b643c3cbcffe /app-emacs/consult
parentdev-dotnet/gentoo-dotnet-maintainer-tools: new package; add 2.0.1 & 2.9999 (diff)
downloadgentoo-f47bbcf675b0977c877caa9aa19e5484523041d9.tar.gz
gentoo-f47bbcf675b0977c877caa9aa19e5484523041d9.tar.bz2
gentoo-f47bbcf675b0977c877caa9aa19e5484523041d9.zip
app-emacs/consult: bump to 1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/consult')
-rw-r--r--app-emacs/consult/Manifest1
-rw-r--r--app-emacs/consult/consult-1.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/consult/Manifest b/app-emacs/consult/Manifest
index 00b1089ff380..2f608ad9a0ef 100644
--- a/app-emacs/consult/Manifest
+++ b/app-emacs/consult/Manifest
@@ -1,2 +1,3 @@
DIST consult-0.35.tar.gz 103472 BLAKE2B 5e47d40bd67811f40ef27f67b508d0fabdbc3bd552ee990e9418b59eedcebfb69241dfeae4a9f084514fc4eb102e17ab7efa4c4e80020d2cd8cd1cd80447aa13 SHA512 a2ee01c970bddd8367c8fe3094483bd5710f1bdbfd3b278e26d443ec42e91dee64b583272ac37e52f198f75554c95f97cd774b7f85b1a1c0d28b9a3905c77721
DIST consult-1.0.tar.gz 103340 BLAKE2B bb4f31b8145fc490e3413e813ae17b904fae17dc5bb9b8381fea916ff5e49ba2e25ab41f5a6711a7bebae8a0a7e5074d1274482d89dd1818c872bc0c1860db78 SHA512 354486706863ed7bd9e6445afeb777a2b1dc9ae805c0cb20ed9f0f501cde5fa6e10800ae0f036c46121920c7b0c1a4733c2e97f8138166bc0d84c31f711d6f10
+DIST consult-1.1.tar.gz 103352 BLAKE2B 8ad8eff3d65013de40f9ee10abaa6ea39acb6b96543d533bc4a272139778445863d26d06a88a759215ee46a95cc68595e8b3eb4e91db911b6b6f104e97a47cce SHA512 687266605f2b8fa9260362aabacd8508acb5239fa72061efbc002d311cf5ebef6fce8795729ab3fc2915de3455e1744dc9980dba422495340349e8c426c44a28
diff --git a/app-emacs/consult/consult-1.1.ebuild b/app-emacs/consult/consult-1.1.ebuild
new file mode 100644
index 000000000000..7b1398601c9b
--- /dev/null
+++ b/app-emacs/consult/consult-1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Consulting complete-read for GNU Emacs"
+HOMEPAGE="https://github.com/minad/consult/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-28.1"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}