summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-12 01:04:25 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-12 01:04:25 +0200
commit61b46982ca596f9b4e88c3c426e79559b3a39caf (patch)
tree6fa0e8e3dfe0e223c1af948397bd262b5f95cee2 /app-emacs/ef-themes
parentapp-emacs/emms: bump to 20 (diff)
downloadgentoo-61b46982ca596f9b4e88c3c426e79559b3a39caf.tar.gz
gentoo-61b46982ca596f9b4e88c3c426e79559b3a39caf.tar.bz2
gentoo-61b46982ca596f9b4e88c3c426e79559b3a39caf.zip
app-emacs/ef-themes: bump to 1.7.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/ef-themes')
-rw-r--r--app-emacs/ef-themes/Manifest1
-rw-r--r--app-emacs/ef-themes/ef-themes-1.7.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/ef-themes/Manifest b/app-emacs/ef-themes/Manifest
index 619580e8374a..67f73da4e8d6 100644
--- a/app-emacs/ef-themes/Manifest
+++ b/app-emacs/ef-themes/Manifest
@@ -1 +1,2 @@
DIST ef-themes-1.4.0.tar.gz 163456 BLAKE2B b3939d467ebf8c57c3975b5bd449bd419fa334febc2d792323b2b14c967e98a34537a766b350c668ff4e893eddd23a55104f7a7af4f437a21bf8e0006dc9fd17 SHA512 ddbad5f6829911cc8806b865ae0f7ef8741224a37b1f8c82bdc66ed0cc8475d1b76707b57bbf34a98bb71d3c9e8ea25d065a79efc1a5803a901f8e08968c83f9
+DIST ef-themes-1.7.0.tar.gz 180301 BLAKE2B f9e0c152cc19c60ccfe27036d33e274d50deee016d56f154ca1cce5350bd3c23bcf73005ea890226e9e665cc284fb1e4e1328a0a66d79f0abb2b725c4d2780f4 SHA512 07cce282ea87af53349195b0fe35d1c89156f3456f09ababe3dbacdb2a00bc90f505d935504d6cd5f5fd6ef4f997102269e854ec4cea4c35441e3b5118f2b7d1
diff --git a/app-emacs/ef-themes/ef-themes-1.7.0.ebuild b/app-emacs/ef-themes/ef-themes-1.7.0.ebuild
new file mode 100644
index 000000000000..e12280ff911b
--- /dev/null
+++ b/app-emacs/ef-themes/ef-themes-1.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Colourful and legible themes for GNU Emacs"
+HOMEPAGE="https://github.com/protesilaos/ef-themes/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.org README.md README.org contrast-ratios.org )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+
+ elisp_src_compile
+ elisp-make-autoload-file
+}